0

I have some weird unmet dependencies i've tried everything to fix them. Here is the output of sudo apt-get dist-upgrade.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Failed
The following packages have unmet dependencies:
 freeglut3 : Depends: libgl1-mesa-glx or
                      libgl1
 gnome-session-bin : Depends: libgl1-mesa-glx or
                              libgl1
 indicator-network : Depends: unity8 (>= 7.82) but it is not going to be installed
 libcanberra-pulse : Depends: pulseaudio but it is not going to be installed
 libcheese-gtk23 : Depends: libcheese7 (>= 3.4.0) but it is not going to be installed
 libcogl15 : Depends: libegl1-mesa-drivers
             Depends: libgl1-mesa-glx
 libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 10.1.3-0ubuntu0.5) or
                            libgl1-mesa-glx-lts-utopic but it is not going to be installed or
                            libgl1-mesa-glx-lts-vivid but it is not going to be installed
 libglamor0 : Depends: libgl1-mesa-glx or
                       libgl1
 libglew1.10 : Depends: libgl1-mesa-glx or
                        libgl1
 libglewmx1.10 : Depends: libgl1-mesa-glx or
                          libgl1
 libgnome-desktop-3-7 : Depends: libgl1-mesa-glx or
                                 libgl1
 libqt5gui5 : Depends: libgl1-mesa-glx or
                       libgl1
              Depends: libgles2-mesa (>= 7.8.1) or
                       libgles2
 libqt5quick5 : Depends: libgl1-mesa-glx or
                         libgl1
 libsoup2.4-1 : Depends: glib-networking (>= 2.32.0) but it is not going to be installed
 libstdc++6 : Depends: gcc-4.9-base (= 4.9.2-0ubuntu1~14.04) but 4.9.3-0ubuntu4 is to be installed
 libubuntu-application-api-mirserver1 : Depends: libmirserver18 (>= 0.1.8+14.04.20140408.1) but it is not going to be installed
 libunity-mir1 : Depends: libmirserver18 (>= 0.1.8+14.04.20140411) but it is not going to be installed
 libwebkitgtk-1.0-0 : Depends: libjavascriptcoregtk-1.0-0 (= 2.4.8-1ubuntu1~ubuntu14.04.1) but it is not going to be installed
                      Depends: libenchant1c2a (>= 1.6.0) but it is not going to be installed
                      Depends: libgl1-mesa-glx or
                               libgl1
                      Depends: libharfbuzz-icu0 (>= 0.9.18) but it is not going to be installed
                      Recommends: gstreamer1.0-plugins-good but it is not going to be installed
 libwebkitgtk-3.0-0 : Depends: libjavascriptcoregtk-3.0-0 (= 2.4.8-1ubuntu1~ubuntu14.04.1) but it is not going to be installed
                      Depends: libenchant1c2a (>= 1.6.0) but it is not going to be installed
                      Depends: libgl1-mesa-glx or
                               libgl1
                      Depends: libharfbuzz-icu0 (>= 0.9.18) but it is not going to be installed
                      Recommends: gstreamer1.0-plugins-good but it is not going to be installed
 nux-tools : Depends: libgl1-mesa-glx or
                      libgl1
 system-config-printer-gnome : Depends: packagekit-system-interface
 x11-utils : Depends: libgl1-mesa-glx or
                      libgl1
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Internal error, Upgrade broke stuff

For example the first one freeglut3 : Depends: libgl1-mesa-glx or libgl1 I already have libgl1-mesa-glx installed. i'm pretty sure i have all of the dependencies installed but it says they aren't. I'm not sure what to do.

1

You're trying to install package from a newer repo but that doesn't have access to a repo with the newer dependencies.Edit the /etc/apt/sources.list file

# deb cdrom:[Ubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140417)]/ trusty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://in.archive.ubuntu.com/ubuntu/ trusty main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://in.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://in.archive.ubuntu.com/ubuntu/ trusty universe
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty universe
deb http://in.archive.ubuntu.com/ubuntu/ trusty-updates universe
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://in.archive.ubuntu.com/ubuntu/ trusty multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty multiverse
deb http://in.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://in.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu trusty-security main restricted
deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
deb http://security.ubuntu.com/ubuntu trusty-security universe
deb-src http://security.ubuntu.com/ubuntu trusty-security universe
deb http://security.ubuntu.com/ubuntu trusty-security multiverse
deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu trusty main
deb-src http://extras.ubuntu.com/ubuntu trusty main

heres an example of /etc/apt/sources.list file also goto Software and Updates from unity and remove non critical repos then do a

sudo apt-get update
sudo apt-get install -f
sudo dpkg --configure -a

I strongly suggest eliminating repositories of different versions from your sources.list -- as others have already said, it's a recipe for a broken system (with a preferences file, you can manage some mixing, usually it's good practice just to avoid mixing versions).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.