12

I have a hp pavilion dv6 with xubuntu installed. however there isn't a way to change the screen brightness, i tried the fn plus scroll keys to no avail, any ideas?

  • Same here. cannot change brightness with Fn + arrow keys. – Stann Oct 29 '11 at 17:46
  • Have you solved this issue? – pl1nk Jun 27 '12 at 22:26
11

Package name is xfce4-power-manager-plugins. Solved my brightness problem in xubuntu 10.04.2.

| improve this answer | |
  • 2
    I'd give you a thousand +1s! – jcora Feb 1 '13 at 21:32
  • So I have this package installed, what should I do next? – Klesun Dec 3 '19 at 9:14
7
echo 1 | sudo tee /sys/class/backlight/acpi_video0/brightness

You can change:

  • Brightness from 1 to 10.
  • acpi_video0 or acpi_video1
| improve this answer | |
2

XFCE has a panel applet for changing brightness, I don't remember if it's installed, so search in packages (e.g. in synaptic) for XFCE and brightness. Then right-click on the panel to add it.

| improve this answer | |
  • After installing additional power manager package I could add a brightness applet to the panel – Nicky De Maeyer Feb 7 '12 at 10:39
1
  1. Open your terminal
  2. Type sudo apt-get install xfce4-power-manager-plugins
  3. Enter your password and press y key to continue
  4. Right-click on the panel, Panel-> Panel Preferences...
  5. Come to the Items tab, click on Add new items button (+) and search for Power Manager Plugin
  6. Select it and click on the Add button
| improve this answer | |
0

You need to download the following files in /etc/acpi/ directory

Download video_brightnessup.sh from here

Download video_brightnessdown.sh from here

After replacing these scripts

No reboot or logout required, simply press your function combination on your laptop to change brightness. Try to press FN + Up/Down Arrow.

| improve this answer | |
  • did absolutely nothing :/ – Adam Wilkins Oct 27 '11 at 18:22
0

I had this problem, i unchecked "Power Manager" from "Application Autostart" list in Settings -> Session and Startup and added another application with this command xfce4-power-manager --no-daemon then i have not have this problem yet.

| improve this answer | |
0

I've had this problem as well.

What fixed it for me was adding acpi_backlight=vendor to the kernel boot line. For more information see Brightness not working on an HP Pavilion Dv6 with a ATI Radeon HD6770M.

After doing this, I could change my brightness normally using the F2 and F3 keys.

| improve this answer | |
0

What worked for me was modifying the /etc/default/grub file.

Change the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Then in a terminal sudo update-grub and reboot.

More info here.

| improve this answer | |
-1

You can use xgamma. The default value is 1.0, higher is brighter, lower is darker.

Example xgamma -gamma 0.9.

| improve this answer | |
  • not looking to change the gamma, i want to change the backlight brightness – Adam Wilkins Oct 27 '11 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.