2

I am trying to upgrade ubuntu 14.04 but I have somehow messed up my packaging system. When I run sudo do sudo do-release-upgrade I get the following message and the upgrade is aborted:

An unresolvable problem occurred while calculating the upgrade.

This can be caused by: * Upgrading to a pre-release version of Ubuntu * Running the current pre-release version of Ubuntu * Unofficial software packages not provided by Ubuntu

I have looked around on the internet and found similar problems. However, when I check the /var/log/dist-upgrade/apt.log for broken packages, it get several hundred lines of broken packages. I the cases I have found so far, only a few packages hass been broken. The first hundred or so lines of the output containing the term "Broken" are

Broken apt:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libapt-pkg4.12:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libgl1-mesa-dri:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libqt5core5a:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken texlive-binaries:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libwebkitgtk-3.0-0:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken texlive-latex-base:amd64 Depends on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (>= 2014.20140512.33982)
Broken systemd:amd64 Conflicts on systemd-services [ amd64 ] < 204-5ubuntu20.15 > ( admin )
Broken systemd:amd64 Conflicts on systemd-services [ i386 ] < none > ( none )
Broken librevenge-0.0-0:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken python3-apt:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 1.0.1ubuntu2.10 -> 1.0.9.7ubuntu4.2 > ( admin ) (>= 1.0.9.7ubuntu4)
Broken ure:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken xserver-xorg-core:amd64 Conflicts on xserver-xorg-video-modesetting [ amd64 ] < 0.8.1-1build1 > ( x11 )
Broken uno-libs3:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken unity-control-center:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 1.3.10)
Broken libqt5dbus5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libqt5qml5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libopencv-core2.4:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken apt-utils:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken texlive-latex-recommended:amd64 Depends on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (>= 2014.20140512.33982)
Broken libqt5gui5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.1)
Broken python-apt:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 1.0.1ubuntu2.10 -> 1.0.9.7ubuntu4.2 > ( admin ) (>= 1.0.9.7ubuntu4)
Broken libqt5quick5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libyelp0:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 1.3.10)
Broken libxapian22:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libicu52:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken qml-module-qtquick2:amd64 Depends on libqt5quick5 [ amd64 ] < 5.2.1-3ubuntu15.1 -> 5.4.1-1ubuntu5 > ( libs ) (>= 5.4.1)
Broken qml-module-qtquick2:amd64 Depends on libqt5quick5-gles [ amd64 ] < none -> 5.4.1-0ubuntu3 > ( universe/libs ) (>= 5.4.1)
Broken qml-module-qtquick2:amd64 Depends on qtdeclarative-abi-5-4-1 [ amd64 ] < none > ( none )
Broken libdee-1.0-4:amd64 Depends on libicu52 [ amd64 ] < 52.1-3ubuntu0.4 -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken libreoffice-core:amd64 Depends on ure [ amd64 ] < 4.2.8-0ubuntu3 -> 4.4.6~rc3-0ubuntu1 > ( libs ) (>= 4.2~)
Broken qtchooser:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken qml-module-qtquick-window2:amd64 Depends on qtdeclarative-abi-5-4-1 [ amd64 ] < none > ( none )
Broken qtdeclarative5-qtquick2-plugin:amd64 Depends on qml-module-qtquick2 [ amd64 ] < none -> 5.4.1-1ubuntu5 > ( libs )
Broken cpp:amd64 Depends on cpp-4.9 [ amd64 ] < none -> 4.9.2-10ubuntu13 > ( interpreters ) (>= 4.9.2-1~)
Broken libkpathsea6:amd64 Breaks on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (< 2014)
Broken libopencv-imgproc2.4:amd64 Depends on libopencv-core2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken libqt5sql5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken gcc:amd64 Depends on cpp [ amd64 ] < 4:4.8.2-1ubuntu6 -> 4:4.9.2-2ubuntu2 > ( interpreters ) (>= 4:4.9.2-2ubuntu2)
Broken zenity:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 1.3.10)
Broken empathy:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 1.3.10)
Broken libqt5sql5-sqlite:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.3.0)
Broken mcp-account-manager-uoa:amd64 Depends on empathy [ amd64 ] < 3.8.6-0ubuntu9.2 -> 3.12.9-1ubuntu1.1 > ( gnome ) (= 3.12.9-1ubuntu1.1)
Broken qtdeclarative5-window-plugin:amd64 Depends on qml-module-qtquick-window2 [ amd64 ] < none -> 5.4.1-1ubuntu5 > ( libs )
Broken libqt5network5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken gir1.2-webkit-3.0:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 2.4.6)
Broken zeitgeist-core:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.0.2)
Broken texlive-pictures:amd64 Depends on texlive-latex-recommended [ amd64 ] < 2013.20140215-1 -> 2014.20141024-2ubuntu1 > ( tex ) (>= 2014)
Broken libqt5widgets5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken texlive-latex-extra:amd64 Depends on texlive-pictures [ amd64 ] < 2013.20140215-1 -> 2014.20141024-2ubuntu1 > ( tex ) (>= 2014)
Broken signon-plugin-oauth2:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken ubuntu-release-upgrader-gtk:amd64 Depends on gir1.2-webkit-3.0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs )
Broken libclutter-1.0-0:amd64 Breaks on libcogl15 [ amd64 ] < 1.16.2-1 > ( libs )
Broken texlive-font-utils:amd64 Depends on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (>= 2014.20140512.33982)
Broken libopenexr6:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken gir1.2-dee-1.0:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.2.7+13.10.20130924.1)
Broken update-manager:amd64 Depends on ubuntu-release-upgrader-gtk [ amd64 ] < 1:0.220.8 -> 1:15.04.14.3 > ( admin )
Broken libharfbuzz-icu0:amd64 Depends on libicu52 [ amd64 ] < 52.1-3ubuntu0.4 -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken compiz-core:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libproxy1:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken update-notifier:amd64 Depends on update-manager-gnome [ amd64 ] < none > ( none )
Broken update-notifier:amd64 Depends on update-manager [ amd64 ] < 1:0.196.14 -> 1:15.04.7.1 > ( gnome ) (>= 1:0.165)
Broken update-notifier:amd64 Depends on ubuntu-release-upgrader-gtk [ amd64 ] < 1:0.220.8 -> 1:15.04.14.3 > ( admin )
Broken libreoffice-common:amd64 Depends on ure [ amd64 ] < 4.2.8-0ubuntu3 -> 4.4.6~rc3-0ubuntu1 > ( libs )
Broken compiz-plugins-default:amd64 Depends on compiz-core [ amd64 ] < 1:0.9.11.3+14.04.20150313-0ubuntu1 -> 1:0.9.12.1+15.04.20150922-0ubuntu1 > ( x11 ) (= 1:0.9.12.1+15.04.20150922-0ubuntu1)
Broken libedataserver-1.2-18:amd64 Depends on libicu52 [ amd64 ] < 52.1-3ubuntu0.4 -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 Depends on qml-module-qtquick2 [ amd64 ] < none -> 5.4.1-1ubuntu5 > ( libs )
Broken qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 Depends on qtdeclarative5-qtquick2-plugin [ amd64 ] < 5.2.1-3ubuntu15.1 -> 5.4.1-1ubuntu5 > ( libs )
Broken qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken qml-module-qtgraphicaleffects:amd64 Depends on qml-module-qtquick2 [ amd64 ] < none -> 5.4.1-1ubuntu5 > ( libs )
Broken libmwaw-0.3-3:amd64 Depends on librevenge-0.0-0 [ amd64 ] < none -> 0.0.1-3 > ( libs )
Broken libqt5svg5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libllvm3.6:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libprotobuf9:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libqt5test5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libodfgen-0.1-1:amd64 Depends on librevenge-0.0-0 [ amd64 ] < none -> 0.0.1-3 > ( libs )
Broken gir1.2-unity-5.0:amd64 Depends on gir1.2-dee-1.0 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs )
Broken texlive-extra-utils:amd64 Depends on texlive-latex-base [ amd64 ] < 2013.20140215-1 -> 2014.20141024-2ubuntu1 > ( tex ) (>= 2014)
Broken signond:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.3.0)
Broken account-plugin-salut:amd64 Depends on empathy [ amd64 ] < 3.8.6-0ubuntu9.2 -> 3.12.9-1ubuntu1.1 > ( gnome ) (= 3.12.9-1ubuntu1.1)
Broken libsignon-extension1:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.3.0)
Broken libexiv2-13:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken account-plugin-aim:amd64 Depends on empathy [ amd64 ] < 3.8.6-0ubuntu9.2 -> 3.12.9-1ubuntu1.1 > ( gnome ) (= 3.12.9-1ubuntu1.1)
Broken libqt5organizer5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libcmis-0.5-5:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken firefox:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libpoppler49:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken g++:amd64 Depends on cpp [ amd64 ] < 4:4.8.2-1ubuntu6 -> 4:4.9.2-2ubuntu2 > ( interpreters ) (>= 4:4.9.2-2ubuntu2)
Broken ibus-qt4:amd64 Depends on libicu52 [ amd64 ] < 52.1-3ubuntu0.4 -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken account-plugin-jabber:amd64 Depends on empathy [ amd64 ] < 3.8.6-0ubuntu9.2 -> 3.12.9-1ubuntu1.1 > ( gnome ) (= 3.12.9-1ubuntu1.1)
Broken libopencv-highgui2.4:amd64 Depends on libopencv-imgproc2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken account-plugin-yahoo:amd64 Depends on empathy [ amd64 ] < 3.8.6-0ubuntu9.2 -> 3.12.9-1ubuntu1.1 > ( gnome ) (= 3.12.9-1ubuntu1.1)
Broken libqt5qml-graphicaleffects:amd64 Depends on qml-module-qtgraphicaleffects [ amd64 ] < none -> 5.4.1-1ubuntu1 > ( libs )
Broken unity-control-center-signon:amd64 Depends on unity-control-center [ amd64 ] < 14.04.3+14.04.20150916-0ubuntu1 -> 15.04.0+15.04.20150410-0ubuntu1 > ( gnome )
Broken libqapt3:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libegl1-mesa:amd64 Depends on libgl1-mesa-dri [ amd64 ] < 10.1.3-0ubuntu0.5 -> 10.5.9-2ubuntu1~vivid2 > ( libs ) (= 10.5.9-2ubuntu1~vivid2)
Broken apt-transport-https:amd64 Depends on libapt-pkg4.12 [ amd64 ] < 1.0.1ubuntu2.10 -> 1.0.9.7ubuntu4.2 > ( admin ) (>= 1.0.9.7ubuntu4.2)
Broken qml-module-qtquick-layouts:amd64 Depends on libqt5gui5 [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.3.0)
Broken qml-module-qtquick-layouts:amd64 Depends on libqt5gui5-gles [ amd64 ] < none -> 5.4.1+dfsg-0ubuntu2 > ( universe/libs ) (>= 5.3.0)
Broken qml-module-qtquick-layouts:amd64 Depends on qtbase-abi-5-4-1 [ amd64 ] < none > ( none )
Broken thunderbird:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken signon-ui-x11:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libopencv-features2d2.4:amd64 Depends on libopencv-imgproc2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken libunity-protocol-private0:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.0.0)
Broken libwpd-0.10-10:amd64 Depends on librevenge-0.0-0 [ amd64 ] < none -> 0.0.1-3 > ( libs )
Broken lshw:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken evolution-data-server:amd64 Depends on libedataserver-1.2-18 [ amd64 ] < 3.10.4-0ubuntu1.5 -> 3.12.11-0ubuntu1.15.04.1 > ( libs ) (>= 3.12.9-0ubuntu1)
Broken unity-scope-musicstores:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 0.5.2)
Broken kubuntu-debug-installer:amd64 Depends on libqapt3 [ amd64 ] < none -> 3.0.0-0ubuntu2.2 > ( universe/kde )
Broken libreoffice-base-core:amd64 Depends on libreoffice-core [ amd64 ] < 1:4.2.8-0ubuntu3 -> 1:4.4.6~rc3-0ubuntu1 > ( editors ) (= 1:4.4.6~rc3-0ubuntu1)
Broken libwpg-0.3-3:amd64 Depends on librevenge-0.0-0 [ amd64 ] < none -> 0.0.1-3 > ( libs )
Broken kde-runtime:amd64 Depends on libexiv2-13 [ amd64 ] < none -> 0.24-4.1 > ( libs )
Broken libnux-4.0-0:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken python-xapian:amd64 Depends on libxapian22 [ amd64 ] < 1.2.16-2ubuntu1 -> 1.2.19-1 > ( libs ) (>= 1.2.19)
Broken unity-scope-gdrive:amd64 Depends on gir1.2-dee-1.0 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs )
Broken unity-lens-music:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.0.2)
Broken libgoa-backend-1.0-1:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 2.1.90)
Broken texlive-music:amd64 Depends on texlive-latex-base [ amd64 ] < 2013.20140215-1 -> 2014.20141024-2ubuntu1 > ( tex ) (>= 2014)
Broken libqt5xml5:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.3.0)
Broken libcoin80:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libqapt3-runtime:amd64 Depends on libqapt3 [ amd64 ] < none -> 3.0.0-0ubuntu2.2 > ( universe/kde )
Broken libgbm1:amd64 Depends on libgl1-mesa-dri [ amd64 ] < 10.1.3-0ubuntu0.5 -> 10.5.9-2ubuntu1~vivid2 > ( libs ) (= 10.5.9-2ubuntu1~vivid2)
Broken zeitgeist:amd64 Depends on zeitgeist-core [ amd64 ] < 0.9.14-0ubuntu4.1 -> 0.9.14-2.2ubuntu3 > ( utils )
Broken signon-ui:amd64 Depends on signon-ui-x11 [ amd64 ] < none -> 0.17+15.04.20150410-0ubuntu1 > ( gnome )
Broken signon-ui:amd64 Depends on ubuntu-system-settings-online-accounts [ amd64 ] < none -> 0.6+15.04.20150409-0ubuntu1 > ( universe/gnome ) (>= 0.4)
Broken libptexenc1:amd64 Breaks on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (< 2014)
Broken librhythmbox-core8:amd64 Depends on libwebkitgtk-3.0-0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs ) (>= 1.3.10)
Broken libopencv-flann2.4:amd64 Depends on libopencv-core2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken libreoffice-math:amd64 Depends on libreoffice-core [ amd64 ] < 1:4.2.8-0ubuntu3 -> 1:4.4.6~rc3-0ubuntu1 > ( editors ) (= 1:4.2.8-0ubuntu3)
Broken libwinpr-thread0.1:amd64 Breaks on libfreerdp1 [ amd64 ] < 1.0.2-2ubuntu1 > ( libs ) (< 1.1.0~git20140921.1.440916e+dfsg-1)
Broken rhythmbox-plugins:amd64 Depends on librhythmbox-core8 [ amd64 ] < 3.0.2-0ubuntu2 -> 3.1-1ubuntu3 > ( libs ) (= 3.1-1ubuntu3)
Broken luatex:amd64 Depends on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (>= 2014)
Broken libcogl20:amd64 Depends on libgbm1 [ amd64 ] < 10.1.3-0ubuntu0.5 -> 10.5.9-2ubuntu1~vivid2 > ( libs ) (>= 8.1~0)
Broken libreoffice-writer:amd64 Depends on libreoffice-base-core [ amd64 ] < 1:4.2.8-0ubuntu3 -> 1:4.4.6~rc3-0ubuntu1 > ( editors ) (= 1:4.4.6~rc3-0ubuntu1)
Broken python3-cupshelpers:amd64 Breaks on python-cupshelpers [ amd64 ] < 1.4.3+20140219-0ubuntu2.6 > ( gnome ) (< 1.5.0+20140805-0ubuntu3)
Broken libopencv-video2.4:amd64 Depends on libopencv-imgproc2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken libebackend-1.2-7:amd64 Depends on libedataserver-1.2-18 [ amd64 ] < 3.10.4-0ubuntu1.5 -> 3.12.11-0ubuntu1.15.04.1 > ( libs ) (>= 3.12.9-0ubuntu1)
Broken gnome-system-monitor:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libicu52:i386 Depends on libstdc++6 [ i386 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken unity-lens-video:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 0.5.2)
Broken libical1a:amd64 Breaks on libical1 [ amd64 ] < 1.0-0ubuntu1 > ( libs )
Broken unity-scope-home:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.2.0daily12.12.05)
Broken libglibmm-2.4-1c2a:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken texlive-metapost:amd64 Depends on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (>= 2014.20140512.33982)
Broken libwps-0.3-3:amd64 Depends on librevenge-0.0-0 [ amd64 ] < none -> 0.0.1-3 > ( libs )
Broken compiz:amd64 Depends on compiz-core [ amd64 ] < 1:0.9.11.3+14.04.20150313-0ubuntu1 -> 1:0.9.12.1+15.04.20150922-0ubuntu1 > ( x11 ) (>= 1:0.9.12.1+15.04.20150922-0ubuntu1)
Broken unity-lens-photos:amd64 Depends on gir1.2-dee-1.0 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.2.5)
Broken libaccounts-qt5-1:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.3.0)
Broken unity-lens-applications:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.0.2)
Broken rhythmbox-plugin-cdrecorder:amd64 Depends on librhythmbox-core8 [ amd64 ] < 3.0.2-0ubuntu2 -> 3.1-1ubuntu3 > ( libs ) (>= 3.0)
Broken zeitgeist-datahub:amd64 Depends on zeitgeist-core [ amd64 ] < 0.9.14-0ubuntu4.1 -> 0.9.14-2.2ubuntu3 > ( utils ) (>= 0.9.10~)
Broken libqpdf13:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libvtk5.8:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libxml2:i386 Depends on libicu52 [ i386 ] < none -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken m-tx:amd64 Depends on texlive-binaries [ amd64 ] < 2013.20130729.30972-2build3 -> 2014.20140926.35254-6build1 > ( tex ) (>= 2014.20140512.33982)
Broken libcamel-1.2-49:amd64 Depends on libicu52 [ amd64 ] < 52.1-3ubuntu0.4 -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken libabw-0.1-1:amd64 Depends on librevenge-0.0-0 [ amd64 ] < none -> 0.0.1-3 > ( libs )
Broken libe-book-0.1-1:amd64 Depends on libicu52 [ amd64 ] < 52.1-3ubuntu0.4 -> 52.1-8ubuntu0.2 > ( libs ) (>= 52~m1-1~)
Broken rhythmbox-plugin-zeitgeist:amd64 Depends on zeitgeist-core [ amd64 ] < 0.9.14-0ubuntu4.1 -> 0.9.14-2.2ubuntu3 > ( utils )
Broken hud:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.2.7+13.10.20130924.1)
Broken libopencv-calib3d2.4:amd64 Depends on libopencv-features2d2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken gir1.2-rb-3.0:amd64 Depends on librhythmbox-core8 [ amd64 ] < 3.0.2-0ubuntu2 -> 3.1-1ubuntu3 > ( libs ) (>= 3.1)
Broken unity-lens-files:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 1.0.0)
Broken libopencv-ml2.4:amd64 Depends on libopencv-core2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)
Broken webapp-container:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken apturl:amd64 Depends on gir1.2-webkit-3.0 [ amd64 ] < 2.4.8-1ubuntu1~ubuntu14.04.1 -> 2.4.8-1ubuntu2 > ( libs )
Broken libcwidget3:amd64 Depends on libstdc++6 [ amd64 ] < 4.8.4-2ubuntu1~14.04 -> 4.9.2-10ubuntu13 > ( libs ) (>= 4.9)
Broken libegl1-mesa-dev:amd64 Depends on libegl1-mesa [ amd64 ] < 10.1.3-0ubuntu0.5 -> 10.5.9-2ubuntu1~vivid2 > ( libs ) (= 10.5.9-2ubuntu1~vivid2)
Broken libreoffice-impress:amd64 Depends on libreoffice-core [ amd64 ] < 1:4.2.8-0ubuntu3 -> 1:4.4.6~rc3-0ubuntu1 > ( editors ) (= 1:4.4.6~rc3-0ubuntu1)
Broken compiz-gnome:amd64 Depends on compiz-plugins-default [ amd64 ] < 1:0.9.11.3+14.04.20150313-0ubuntu1 -> 1:0.9.12.1+15.04.20150922-0ubuntu1 > ( x11 ) (= 1:0.9.12.1+15.04.20150922-0ubuntu1)
Broken qtbase5-dev-tools:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken unity:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 0.5.2)
Broken qml-module-ubuntu-onlineaccounts:amd64 Depends on libqt5core5a [ amd64 ] < 5.2.1+dfsg-1ubuntu14.3 -> 5.4.1+dfsg-2ubuntu4.1 > ( libs ) (>= 5.4.0)
Broken libreoffice-draw:amd64 Depends on libreoffice-core [ amd64 ] < 1:4.2.8-0ubuntu3 -> 1:4.4.6~rc3-0ubuntu1 > ( editors ) (= 1:4.4.6~rc3-0ubuntu1)
Broken libunity-core-6.0-9:amd64 Depends on libdee-1.0-4 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs ) (>= 0.5.16)
Broken evolution-data-server-online-accounts:amd64 Depends on libcamel-1.2-49 [ amd64 ] < none -> 3.12.11-0ubuntu1.15.04.1 > ( libs ) (= 3.12.11-0ubuntu1.15.04.1)
Broken context:amd64 Depends on texlive-metapost [ amd64 ] < 2013.20140215-1 -> 2014.20141024-2ubuntu1 > ( universe/tex ) (>= 2014)
Broken friends-dispatcher:amd64 Depends on gir1.2-dee-1.0 [ amd64 ] < 1.2.7+14.04.20140324-0ubuntu1 -> 1.2.7+15.04.20150304-0ubuntu1 > ( libs )
Broken qml-module-qtwebkit:amd64 Depends on qtdeclarative-abi-5-4-1 [ amd64 ] < none > ( none )
Broken libcompizconfig0:amd64 Depends on compiz-core [ amd64 ] < 1:0.9.11.3+14.04.20150313-0ubuntu1 -> 1:0.9.12.1+15.04.20150922-0ubuntu1 > ( x11 ) (= 1:0.9.12.1+15.04.20150922-0ubuntu1)
Broken libfolks-eds25:amd64 Depends on evolution-data-server [ amd64 ] < 3.10.4-0ubuntu1.5 -> 3.12.11-0ubuntu1.15.04.1 > ( gnome ) (>= 3.2.0)
Broken checkbox-gui:amd64 Depends on qtdeclarative5-qtquick2-plugin [ amd64 ] < 5.2.1-3ubuntu15.1 -> 5.4.1-1ubuntu5 > ( libs )
Broken libopencv-objdetect2.4:amd64 Depends on libopencv-highgui2.4 [ amd64 ] < 2.4.8+dfsg1-2ubuntu1 -> 2.4.9+dfsg-1ubuntu4 > ( universe/libs ) (= 2.4.9+dfsg-1ubuntu4)

So far, I have disabled all PPAs and removed a couple of packages. Of course, the number of broken packages decrease but I do not want to remove all packages in the list.

Does anyone have a suggestion on how to proceed?

  • Try restoring your sources list with sudo rm -r /etc/apt/sources* and then sudo software-properties-gtk. When the software-properties window pops up, enable the repositories you need. Note: This will remove ALL of the sources files, so any PPAs you have previously added will need to be re-added. Then do a sudo apt-get upate and try again. – user323419 Jan 15 '16 at 16:00
  • The output of apt-cache policy sudo apt-get check and sudo dpkg -C, just as start. – Braiam Jan 15 '16 at 16:26
3

Assumptions:

  • Started on 14.04
  • Ran sudo do-release-upgrade which attempted to upgrade to 15.04.
  • Upgrade failure happened, because of some issue with some software not being updated fully first (ALWAYS run sudo apt-get update; sudo apt-get dist-upgrade BEFORE running do-release-upgrade)

Assuming both of my assumptions above here are correct, then you've broken your system. The 14.04 to 15.04 direct upgrade path which was a fairly newly introduced upgrade path solution is not a guaranteed-to-work solution - it has broken severly in the past and left people with broken-beyond-easy-fix repairs.

Given that the broken software list you have is insanely large, contains core software in the list, and fixes tried have failed, the only option really left to you is to cleanly install 14.04 or your target release, after backing up the data you wish to keep.

This is, unfortunately, the only true way to fix a horribly broken system; in this case, fixing each package will be extraordinarily difficult and you may be better off just cleanly installing, which is the fastest fix. Back up your data first, though, so you don't lose it, and can restore it after fresh installing.

| improve this answer | |
  • Any idea how OP might have "horribly broken" his system? I'm having the same issue, with similar output, and I've never tampered with anything listed. From my inexperienced research, it seems like a recent Ubuntu update became dependent upon a newer g++ library, which is causing some other packages to be "blocked" somehow. I came across this while trying to build Dolphin Emulator in 14.04, which needed a specific GCC version. I decided to try upgrading to the supported release when that failed, but then this happened... – Michael Hoffmann Jan 19 '16 at 5:43
2

Uninstalling the package mentioned last in the list of broken packages in /var/log/dist-upgrade/apt.log (which in my case was the tex-live package) void that error. I was a bit surprised that one package could generate such a long list of broken packages.

As the upgrade to 15.04 was complete, broken packages appeared once again. This time it seemed to originate from libstc++. Naturally, I did not want to remove that library because of the large number of packages depending on it. So i messed around with apt-get with various arguments (dist-upgrade, update, upgrade etc.) to no success. Finally I removed ubuntu-desktop and unity to see if I could re-install them. Ubuntu desktop since it was listed first and unity since Ubuntu desktop was depending on that package, which were reported as being held when I tried to re-install Ubuntu desktop. As I were unable to re-install Ubuntu desktop I decided to try to upgrade to 15.10 hoping that any issues would be resolved during that process. As the upgrade was complete, I reinstalled Ubuntu desktop and Unity and then, to my big surprise, the system worked.

To summarize, I were not aware the it was necessary to run apt-get dist-upgrade before an upgrade of the system and perhaps that would have resolved the situation. Unfortunately I can not give a direct answer to what caused the system to suddenly work again, but apparently libstdc++ were updated thus allowing all other packages to be updated.

| improve this answer | |
  • Thank you. I think this will solve my problem, similar to OP's. – Michael Hoffmann Jan 19 '16 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.