4

Since a few days now, I think since the last Firefox update, but I can't be sure, because I've been away for a few weeks until Jan, 10th, Firefox is practically not usable any more. It takes forever to load a page (more than a minute) and most of the times doesn't even complete.

I am sure the connection works (it's a fast 1Gbit/s point-to-point fiber with the ISP) because when I use Chrome or Opera, they're flashy fast.

I also believe it can't be the profile/user, since I've also tried creating a new user in Ubuntu. Same effect: Chrome super-fast, Firefox doesn't practically work.

Then, on the same laptop (Lenovo S540) I have Win10 in dual boot, and Firefox 43.0.4 as well in it. So, the thing is that in Win it works perfectly fine, so I guess the problem comes only for the Firefox in Ubuntu.

To further rule out a connection issue (a part from trying both with wifi and eth connection), I've brought the laptop all the way to my office and tried with the connection at work. Well, exactly same thing: Chrome snappy. Firefox unusable.

Am I the only one having this issue?? It's a few days I'm looking online, but I haven't found anybody else's post anywhere about this...

I'm an almost-expert (not professional, but 10+ years of exp) user in Linux and Firefox both, but I really can't understand what's going on here... Is anybody having a hint for me about where to look at next?

  • Don't know what an expert should do (experts should know better), but for a regular non-expert user, I'd advise trying a new Firefox profile. – mikewhatever Jan 15 '16 at 10:00
  • 1
    Other simple things to try: Safe Mode, Reset addons and settings, reinstall Firefox via package manager. – clearkimura Jan 15 '16 at 10:30
  • @mikewhatever As I said above, I've not only tried a new profile, I've also tried creating a fresh Ubuntu user ('virgin' home directory and all...), with the same effect. By saying I'm not beginner, I mean exactly that all the 'standard' attempt have been tried... I'm really trying to figure out why I haven't find anybody else around with a similar problem... – Bill Jan 15 '16 at 11:01
  • @clearkimura I tried the Firefox Refresh procedure... Still have to try reinstalling... but I am a bit in doubt for that, since Firefox it is such a big (and default) part of Ubuntu... – Bill Jan 15 '16 at 11:04
  • Are there any errors in dmesg or syslog? If you run Firefox from the command line are there any errors? Any errors in ~/.xsession-errors? Does top show anything unusual? To dump stack and see what Firefox is doing while hung try cat /proc/$(pidof firefox)/stack – bain Jan 15 '16 at 23:33
2

In the end, after an update to Firefox 44 everything works again, more or less... I don't know if it's really solved, since it's still notably slower than Chrome, but at least is usable. A few days ago I tried the nightly (ver 46) and it had the same problem, so I already started despairing that an update wouldn't solve... But actually it did, so I'm happy. But still curious about what happened...

2

I had a similar problem. Disabling Ubuntu Modifications add-on solved it. According to these answers, it is the interaction of adblock plus and the Ubuntu Modifications add-on.

  • Thanks, I'll try disabling Ubuntu Modifications, but actually I don't have any adblock nor any other add-on... especially after the Firefox Refresh procedure ;-) But I'll see if by chance it works... – Bill Jan 15 '16 at 14:08
  • I have same problems as the answer author. Tryed this solution - it doesn't helped me. – azurkin Jan 18 '16 at 14:04
  • this seems to work for me with ublock origin too – Chris Apr 3 '16 at 16:26
  • Sad but true. Couldn't find related bug report on Launchpad. – Pablo Bianchi Nov 6 '16 at 15:26
0

I've tried several things now to fix this on my system but I think I may finally have a solution as I made the change last night and so far have gone all day & several reboots without any slow browser lookups etc.

I'd heard some time ago about possible problems with IPv6 DNS lookups and that while not specifically an IPv6 problem it had more to do with the routers (like your home router/wifi) not handing IPv6 DNS properly.

Some in those earlier searches had just recommended turning OFF IPv6 DNS altogether but to me that didn't sound like a good solution.

Then I read this link:

https://help.ubuntu.com/community/WebBrowsingSlowIPv6IPv4

And ... specifically the Section labeled Blackhole IPv6 route

In it the author also says turning OFF IPv6 DNS is not a good idea but he shows what he recommends to do instead which is basically to edit :

/etc/sysctl.conf

and add the line:

net.ipv6.conf.all.accept_ra = 0

I did this and rebooted just to make sure everything restarted properly (maybe just restarting networking service would have been enough).

Anyway since then I'm not seeing this problem any more (at least in the last 12 hours of use).

You might give it a shot as again you can always back-out if it doesn't solve your problem?

Brian

0

Try to deactivate certain pre-cognition features. Here is a list (in German).

0

My firefox takes almost a minute to load a page on every install (since Ubuntu 13.10 if I remember correctly). The only way to fix it is go to about:config (you write it where you write the pages url) and search for ipv6. Then change network.dns.disableIPv6 to true (maybe my router doesn't support IPv6 and causes firefox to search for it but it isn't needed yet so you won't have any problem). After this, pages load within 1 sec.

0

Thanks to bmullan. I voted for his answer too(I have not enough points here to be counted though). So I used his link https://help.ubuntu.com/community/WebBrowsingSlowIPv6IPv4

At first I checked IPv6 routes. There were no default route for IPv6 on my computer, then problem must be with Firefox itself. Okey, I tried disabling IPv6 in Firefox using this manual:

**To disable IPv6 in Firefox:**
In the address bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. ...
In the Search field, type network.dns.disableIPv6.
In the list of preferences, double-click network.dns.disableIPv6 to set its value to true.

And it WORKS! My Firefox is alive again after long struggle.

I filed BUG report to Mozilla https://bugzilla.mozilla.org/show_bug.cgi?id=1325781 I hope they can solve this problem sooner rather than later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.