0

Trying to install Tracker search application to index my pdf files. [Found recoll's search result page cluttered.] But everytime I try configure before installing, I get the following error -

checking for LIBTRACKER_BUS... yes
checking for LIBTRACKER_COMMON... yes
checking for LIBTRACKER_DATA... no
configure: error: Package requirements (glib-2.0     >= 2.40.0
                          gio-unix-2.0 >= 2.40.0
                          sqlite3      >= 3.7.9
                          uuid) were not met:

No package 'sqlite3' found
No package 'uuid' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBTRACKER_DATA_CFLAGS
and LIBTRACKER_DATA_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

werunom@linux-matter ~/Downloads/tracker/tracker-1.6.1 $ sudo apt-get install sqlite3
[sudo] password for werunom: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
sqlite3 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

werunom@linux-matter ~/Downloads/tracker/tracker-1.6.1 $ sudo apt-get install uuid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
uuid is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

I am not sure what package I have to install more for the configuration to happen successfully.

Thanks for any help/suggestion.

2
  • Do you know that the Recoll result page is fully and easily customizable by the way ? lesbonscomptes.com/recoll/usermanual/… – medoc Jan 24 '16 at 20:18
  • @medoc - Thanks for pointing to that! I should have searched for it. With this, at least I can give Recoll a try. But still not able to have hands on with Tracker. – Varun Jan 26 '16 at 1:28
-1

Try running sudo apt-get -f install. If this doesn't work you might have to install the packages that are missing manually. However, you could also try adding 3rd party repositories, maybe they serve the packages on ther servers.

2
  • Tried it, but did not help. I think, there is something to do with LIBTRACKER_DATA, but not sure what :D But thanks for suggesting! – Varun Jan 15 '16 at 2:30
  • OP has to install the development packages because he/she tries to compile tracker -1 – A.B. Jan 15 '16 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.