0

I've seen a bunch of posts all around the internet about the Yoga line of laptops having wifi issues on older versions of ubuntu, but it seems this issue was patched in version 15.10. Well I just installed version 15.10 on my Lenovo Yoga 3 11' and I have no wifi connectivity. I'm a complete Linux noob, this is really my first foray into the Linux world outside of some basic Terminal stuff on the server end (I mean basic, like opening text files and navigating directories)

I downloaded Ubuntu 15.10 and created a bootable USB, from there I did a clean install onto my laptop and that's about as far as I have gotten. I was attempting some fixes earlier and I was able to see my wireless NIC but I can't see any of my local networks. All the other potential fixes are talking at a level I just don't operate at yet so I am unable to try them, help?

All my other devices (including bluetooth it seems) are working fine. Touch screen, mouse, keyboard, audio, the works. Just not internet. Thanks guys.

0

Download these files as a .zip file, extract the contents and run:

cd extractedfolder

sudo make install && sudo update-grub && sudo modprobe 8723au

sudo reboot

The last command will reboot your computer, so the changes can take effect, so do not forget to save anything, like documents, or something like that.

2
  • Sorry, forgot the link: github.com/lwfinger/rtl8723au – Gert Otten Jan 15 '16 at 1:41
  • I ran the commands and it didn't work, I tried both the way you mentioned and the way the comments on github mention it (same thing just in a few more steps) and no dice, still says disconnected no connection when I boot up. Is there any way I can check to make sure it was done correctly? I didn't get any errors, no positive feedback either but that's usually the case I believe. – ASatiricalDalek Jan 15 '16 at 2:45
0

What worked for me on my Lenovo Yoga 3 14, running Ubuntu 15.10 live from a USB drive :

  1. In Terminal : sudo modprobe -r ideapad_laptop

  2. In Software Center : make sure the "installation CD" is checked as a software source ( In Software Sources ), then click on the Additional Drivers tab. It showed me that the device ( the laptop ) could use, but wasn't using, some proprietary ( in my case Broadcom ) drivers. I clicked the radio button to use those, clicked a button to make the changes.

  3. Clicked the Network Manager icon, saw all the nearby available wireless networks, signed on to mine, done.

0

For any potential, future googlers. I ended up tethering my phone to my laptop to get it online, from there I was able to run the software update program which acquired the drivers automatically and, upon a reboot, enabled my wifi. Thanks for all the help everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.