0

Got a working screen via HDMI, but the DVI won't go past 1360x768 (a PackardBell Maestro monitor). Had no issues in Windows 7.

I've tried all the xrandr tricks, see the output below:

xrandr

Screen 0: minimum 8 x 8, current 3280 x 1080, maximum 16384 x 16384
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+1360+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080      60.0*+   59.9     50.0  
   1680x1050      60.0  
   1600x900       60.0  
   1440x900       59.9  
   1280x1024      75.0     60.0  
   1280x800       59.8  
   1280x720       60.0     59.9     50.0  
   1152x864       75.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   720x576        50.0  
   720x480        59.9  
   640x480        75.0     72.8     59.9  
DVI-D-1 connected 1360x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0*    59.8  
   1152x864       60.0  
   800x600        72.2     60.3     56.2  
   680x384        60.0     59.8  
   640x480        59.9  
   512x384        60.0  
   400x300        72.2  
   320x240        60.1  


cvt 1920 1080
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

xrandr --newmode "test" 173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

xrandr --addmode DVI-D-1 test
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  37
  Current serial number in output stream:  38

I'm using the latest driver from Nvidia (binary, 352.63) because Nouveau would show a black screen on my second monitor.

I got stuck on manually finding/creating a xorg.conf file and adding some monitor hacks, can anyone help me?

2

The answer here fixed it: http://ubuntuforums.org/showthread.php?t=1812872&page=2

specifically,

gksudo gedit /etc/X11/xorg.conf

change
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0

to

HorizSync 31.0 - 80.0
VertRefresh 56.0 - 75.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.