Ubuntu One works when I login as administrator, but cannot synchronize if I use the normal account (see also here: Ubuntu One does not sync: firewall settings?). Is that normal?


The problem has been solved. I copy here the email sent by UbuntuOne-support.

Great! Everything is now working properly with Ubuntu One. Thank you so much for your help. I'll post your answer to the forum, in case it may help someone else with the same problem. Alberto

----Messaggio originale---- Da: ubuntuone-support@canonical.com Data: 02/11/2011 17.39 A: Ogg: [Ubuntu One #7129] Confused

Hi, Looks like you have switched users. If you log in to Ubuntu One and sync your files, then log into Ubuntu One as a different user on your ocmputer and perform a sync without clearing out the old metadata you will get errors. To fix this please open a Terminal and run the following commands:

u1sdtool -q

rm -rf ~/.local/share/ubuntuone

u1sdtool -c

Let Ubuntu One run for a bit as it recreates your metadata.

Thanks, Duane


Nope, I don't think so. There is no "administrator" account on Linux, so to say. Only root, but you should never run X11 (the graphical environment) as root. So ... in short: NOPE. It's a simple application, which keeps your stuff synced. It's like Wuala, or Dropbox. Same thing, with Ubuntu colors.

They usually sit in the background, watch out for changes, etc. But that's easily accomplished with user rights. No need for sudo, or anything.

  • Thank you for your explanation. However, when I login with the first account created by Ubuntu during the installation (the one I use to update the system) Ubuntu One does its job, when I login with the account I created to do all the rest (navigate, etc.) Ubuntu One does not sync. What might the reason be? Oct 26 '11 at 10:43
  • Some scrip? Some folder or setting won't get created for the other user? I highly suspect one of the mentioned things happen ... please, report this as a bug and we'll see what Canonical says.
    – Apache
    Oct 27 '11 at 16:54
  • I changed my DNS to Google's, as you suggested here: askubuntu.com/questions/57633/… It works fine, but nothing has changed in Ubuntu One. I'll try to report this as a bug. Oct 29 '11 at 21:37
  • Okay, please report back the bug's ID, I'm curious about this one.
    – Apache
    Oct 30 '11 at 9:52
  • Hi Shiki, the problem was solved by ubuntuone-support: it was a matter of authentication. I tried several times to copy the answer below (answer your question), but I got an error. I'll try again later: I think someone else might encounter the same problem. Nov 5 '11 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.