0

After waking from suspend, my wifi doesn't work. I'm using a USB wifi adapter.

In the Network Manager indicator dropdown, "Enable networking" is checked, "enable Wi-Fi" isn't appearing at all.

When I run nmcli nm, the STATE is disconnected, rather than asleep as in this post.

When I run ifconfig, wlan1 doesn't appear at all.

My current solution is to run sudo killall NetworkManager each time I wake my computer. This does reinstate wlan1, and the internet works again.

What's the way forward here? Do I need a new driver? Change a NetworkManager permission? Write a script to killall NetworkManager every wake?

0

Since you know what fixes it via the command line, I'd just place that in a script that automatically runs during wake with the problem solved in a minute or so: how to execute a command after resume from suspend?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.