0

sorry for bringing up this seemingly well known issue again. Meanwhile I spent almost a week on it, including several reinstallations of ubuntu and I am lost.

I am running a laptop with nvidia GM204M [GeForce GTX 965M]. After the standard installation of ubuntu 15.10 everything looked fine. However I found problems with the HDMI output. After some research I found that the "standard" nvidia/nouveau driver seems to have restrictions here and I decided to install the proprietary nvidia driver via the "additional drivers" dialog. This worked seemingly fine.

But after a shutdown I experience the following:

GRUB: Ubuntu (normal startup) -> "black screen" Ctrl-Alt-F1 -> no reaction

Ctrl-Alt-Delete: -> Advanced Options 4.2.0-23-generic recovery mode

-> recovery menu failsafeX

-> running in low-graphics mode OK

-> What would you like to do any input ignored

Ctrl-Alt-F1 -> no reaction

Ctrl-Alt-Delete: -> Advanced Options 4.2.0-23-generic recovery mode

network root

-> console startx

-> nvidia logo appears empty X11 screen (background with mouse cursor) appears

I can open a terminal now

nvidia-detector results in "none"

nvidia-settings opens a graphical editor showing the following (extract) OS Linux-x86_64 driver version 352.63 Display Name: ubutux:2 Server Version 11.0 Server Vendor Version 1.17.2.(11702000) NV Control Version 1.29 Screens 1

I can configure screen resolution etc. So, everything looks good? At least the proprietary driver seems to work in principle

"normal boot" mit acpi=off -> "black screen"

And this posting at least helped me to get back to a partly working system after I got stuck with the proprietary drivers: How to solve black screen problem after installing nvidia drivers on Ubuntu 15.10?

I also tried to install and run the binary drivers from Nvidia - no luck. Yes, I did a full reinstall afterwards to be "clean" again.

Any hints appreciated!

Kind regards

Harald

P.S. I had to remove some information in order to avoid the "spam blocker" . Feel free to ask if you need more details.

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 == vendor : NVIDIA Corporation model : GM204M [GeForce GTX 965M] modalias : pci:v000010DEd000013D9sv00001558sd00007702bc03sc00i00 driver : nvidia-352-updates - distro non-free driver : nvidia-352 - distro non-free recommended driver : xserver-xorg-video-nouveau - distro free builtin

== cpu-microcode.py == driver : intel-microcode - distro non-free

harald@sky:~/ubutux$ vi post harald@sky:~/ubutux$ cat ubuntu-drivers-devices.log == /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 == vendor : NVIDIA Corporation model : GM204M [GeForce GTX 965M] modalias : pci:v000010DEd000013D9sv00001558sd00007702bc03sc00i00 driver : nvidia-352-updates - distro non-free driver : nvidia-352 - distro non-free recommended driver : xserver-xorg-video-nouveau - distro free builtin

== cpu-microcode.py == driver : intel-microcode - distro non-free

lspci

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)

00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)

00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)

00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)

00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)

00:17.0 SATA controller: Intel Corporation Device a102 (rev 31)

00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)

00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)

00:1c.7 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #8 (rev f1)

00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1)

00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)

00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)

00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)

01:00.0 VGA compatible controller: NVIDIA Corporation GM204M [GeForce GTX 965M] (rev a1)

01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)

3b:00.0 Ethernet controller: Qualcomm Atheros Device e0a1 (rev 10)

3c:00.0 SD Host controller: Realtek Semiconductor Co., Ltd. Device 5250 (rev 01)

3d:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)

dpkg

ii nvidia-352 352.63-0ubuntu0.15.10.1 amd64 NVIDIA binary driver - version 352.63

ii nvidia-common 1:0.4.11
amd64 transitional package for ubuntu-drivers-common

ii nvidia-opencl-icd-352 352.63-0ubuntu0.15.10.1 amd64 NVIDIA OpenCL ICD

ii nvidia-prime 0.8.1 amd64 Tools to enable NVIDIA's Prime

ii nvidia-settings 352.21-0ubuntu1 amd64 Tool for configuring the NVIDIA graphics driver harald@sky:~/ubutux$

2

1 Answer 1

0

partly solved: I reinstalled ubuntu 15.10 from scratch as before but didn't encrypt the SSD (in contrast to my former installation)

Then I installed the proprietary nvidia driver via

System Settings -> Software + Updates -> Additional Drivers 352.63 nvidia-352-upgrades and deactivated the "unknown device" (again as before)

after a reboot everything (seems to) work fine

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .