1

Im trying an install of APU drivers along with GPU drivers. I need GPU for rendering, just one monitor would be used, driven by APU.

Using ubuntu 14.04 64 bits, I get (lscpci):

  00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 200 Series]
  01:00.0 VGA compatible controller: NVIDIA Corporation Device 13c2 (rev a1) 

What I have tried already:

  1. Install propietary drivers for apu
  2. Reboot, seems it worked ok
  3. Install Nvidia drivers, got problems loging in again

Had a look at xorg.conf there was only nvidia driver, no more fglrx.

APU is from AMD A8 cpu GPU is Nvidia gtx 970

How can I run both drivers?

  • I once saw this method: 1. copy original empty xorg.conf driver to backup #1. 2. install 1st driver. 3. when works copy xorg.conf over to a backup #2. 4. remove driver/reinstall xorg.conf backup #1. 5. install 2nd driver. 6. when works copy xorg.conf to backup #3. 7. Merge xorg.conf backup #2 with backup #3 to make a new xorg.conf. ... Good luck with it ;-) – Rinzwind Jan 13 '16 at 18:50
  • Thans Rinzwind, will give it a try. When you mention remove driver you mean as sudo-apt remove? – fran35 Jan 13 '16 at 19:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.