1

I'm unable to access my home server remotely although it works fine in LAN. When I try to access it remotely using http://xxx.xxx.xxx.xxx/ I get router control panel page and when I browse http://xxx.xxx.xxx.xxx:8081/ or http://xxx.xxx.xxx.xxx:8080/ the browser gives timeout error (I'm unable to access MySQL DB too)

May you please help me?

Installed LAMP configurations:

  • Linux ubuntu 14.04 x64
  • nmap output (I already get static IP from my ISP):
nmap -sS -O -PI -PT xxx.xxx.xxx.xxx

Starting Nmap 6.40 ( http://nmap.org ) at 2016-01-13 17:10 EET
Nmap scan report for xxx.xxx.xxx.xxx
Host is up (0.0048s latency).
Not shown: 992 filtered ports
PORT STATE SERVICE
21/tcp   open  ftp
22/tcp   open  ssh
80/tcp   open  http
443/tcp  open  https
631/tcp  open  ipp
3306/tcp open  mysql
8080/tcp open  http-proxy
8081/tcp open  blackice-icecap
Warning: OSScan results may be unreliable because we could not find at least 1 open and 1 closed port
Device type: general purpose
Running: Linux 2.6.X|3.X
OS CPE: cpe:/o:linux:linux_kernel:2.6 cpe:/o:linux:linux_kernel:3
OS details: Linux 2.6.9 - 2.6.19, Linux 2.6.9 - 2.6.30, Linux 3.5

OS detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 41.97 seconds
  • Apache 2.4.7
  • /etc/apache2/apache2.conf
Mutex file:${APACHE_LOCK_DIR} default
PidFile ${APACHE_PID_FILE}
Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
HostnameLookups Off
ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf
Include ports.conf

    Options FollowSymLinks
    AllowOverride None
    Require all denied



    AllowOverride None
    Require all granted



    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted


AccessFileName .htaccess


    Require all denied


LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

IncludeOptional conf-enabled/*.conf

IncludeOptional sites-enabled/*.conf
  • /etc/apache2/ports.conf
Listen 80


    Listen 443



    Listen 443


  • /etc/apache2/sites-enabled/000-default.conf

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

  • MySQL 5.5.46
  • /etc/mysql/my.cnf
[client]
port        = 3306
socket      = /var/run/mysqld/mysqld.sock

[mysqld_safe]
socket      = /var/run/mysqld/mysqld.sock
nice        = 0

[mysqld]
user        = mysql
pid-file    = /var/run/mysqld/mysqld.pid
socket      = /var/run/mysqld/mysqld.sock
port        = 3306
basedir     = /usr
datadir     = /var/lib/mysql
tmpdir      = /tmp
lc-messages-dir = /usr/share/mysql
key_buffer      = 16M
max_allowed_packet  = 16M
thread_stack        = 192K
thread_cache_size   = 8
myisam-recover = BACKUP
query_cache_limit   = 1M
query_cache_size= 16M
log_error = /var/log/mysql/error.log
expire_logs_days    = 10
max_binlog_size = 100M

[mysqldump]
quick
quote-names
max_allowed_packet  = 16M

[mysql]

[isamchk]
key_buffer      = 16M

!includedir /etc/mysql/conf.d/
  • Home server
IP Address: 192.168.1.2
Broadcast Address: 192.168.1.255
Subnet Mask: 255.255.255.0
Default Route: 192.168.1.1
Primary DNS: 192.168.1.1
  • Router control panel IP: 192.168.1.1
  • Port Forwarding configurations

Port Forwarding

  • Router control panel IP: 192.168.1.1
  • Port Forwarding configurations (see the attachment plz)
  • netstat output
sudo netstat -napW | grep apache
tcp6 0 0 :::80 :::* LISTEN 860/apache2

sudo netstat -napW | grep mysql
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 4746/mysqld
unix  2  [ ACC ] STREAM LISTENING 1401737  4746/mysqld /var/run/mysqld/mysqld.sock
  • Firewall status (disables in both firewall and the server)
ufw status
Status: inactive
  • Sorry I couldn't format the code well – mbnoimi Jan 13 '16 at 17:25
  • I'm guessing that you have filled in the wrong value for "Remote Host". Set it to "any host" and see if that helps. Then, from the access log, find out what the "Remote Host" should have been, and reconfigure the router. – Jos Jan 13 '16 at 17:26
  • @Jos Where you're pointing to? which value you mean? – mbnoimi Jan 13 '16 at 17:29
  • The one in your screenshot that you have blacked out, in the Settings window next to Remote host. – Jos Jan 13 '16 at 17:32
  • @Jos I'm pretty sure I'm using a correct IP because I checked it out using whatismyipaddress.com – mbnoimi Jan 13 '16 at 17:39
0

Do you have Dynamic DNS set up? Your network is private unless you have a business connection. Even then, you must usually set up port forwarding on your business' router.

I would actually going to Digital Ocean or another VPS provider and doing that instead. You'll have a much easier time, and I've seen some (not DO) providers with $3 USD a month for a small server.

  • No. The Static IP suppose to do the job (I bought it from my ISP) – mbnoimi Jan 13 '16 at 17:26
  • You set up port forwarding on your router's firewall? You need to forward port 80 tcp to that machine. – Derrek Bertrand Jan 13 '16 at 17:29
  • I did as mentioned in the screenshot – mbnoimi Jan 13 '16 at 17:32
  • I see that now. If you access over your lan, but not from outside that, then @Jos is probably right. It is a router config issue. – Derrek Bertrand Jan 13 '16 at 17:33
0

I found out what's the problem.

As soon as I input DMZ to 192.168.1.2 the problem solved.

Thank you guys for help

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.