I am trying to install docker on Ubuntu 14.04, however, I can't get beyond the first step documented here: https://docs.docker.com/engine/installation/ubuntulinux/

$ sudo apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.VB8X4gv8Ty --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
gpg: requesting key 2C52609D from hkp server p80.pool.sks-keyservers.net
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

The key server is timing out after couple of minutes of running this command. Anyone else facing this issue? I saw some posts about firewalls blocking port 11371. But I'm already using port 80, so that shouldn't be the issue.

What can I do to update the keys manually on Ubuntu if the preferred option of getting it from the key server with apt-key is not working?

See the repo issue for details: https://github.com/docker/docker/issues/13555

The protocol hkp uses the port 11371 as default.

The pool hkp://p80.pool.sks-keyservers.net is a subset of servers which are also available on port 80. It's more friendly to firewalls and companies.

For some reason, most docker documentations and tutorials are giving that p80 pool for installation, without further explanation.

The thing is, this is a small pool of servers and they fail very often in practice. (The fact that most tutorials are sending people to that small pool probably doesn't help either).

You should use hkp://ha.pool.sks-keyservers.net if you want any of stability. Open the port on your firewall if you have firewalls.

It is a pool with only high availability setup, as the name suggest. Meaning servers MUST be behind load balancers to be accepted.

It seems it happens quite often.

https://github.com/docker/docker/issues/13555

So, I was able to get this working by running

sudo apt-get install docker-engine

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.