3

I installed Ubuntu and my wifi worked flawlessly for about a week. Then one day it was slow to the point of unusable and so it remains until now. The problem is not the network itself as my desktop has perfectly fine wifi. I uninstalled Ubuntu and reinstalled - this did not fix the problem. I've read a ton of very confusing answers proporting to solve this problem and I have spent a lot of time copying a hodgepodge of code from these answers to the terminal. Nothing has worked. I tried to install Fedora and it wouldn't install so I'm stuck with Ubuntu. help! :)

edit: I also bought a panda wireless USB adapter to solve this problem but it doesn't fix it. the connection is still slow to the point of timing out.

Edit: I just installed MINT and the same issue arises. Regardless I'm confident it isn't the network or the laptop I'm on. When I connect via a physical connection it works just fine and as i said, the wireless worked prior. It also worked when I was using windows on the same machine.

  • Have you tried updating the BIOS? Have you tried sudo apt-get update && sudo apt-get upgrade && sudo apt-get install linux-firmware-nonfree? – QwertyChouskie Jan 16 '16 at 21:30
  • I did what you said and it installed without error- but it didn't fix the wifi problem. – William Jan 17 '16 at 8:29
  • Make sure to reboot after running the command. – QwertyChouskie Jan 18 '16 at 23:51
4
+50

Your wireless interface is softblocked

Try sudo rfkill unblock wlan0

| improve this answer | |
1

There's a few things you can try, but honestly this is very network card dependent; it would be helpful to post the output of lspci and dmesg to check for sure. Looking online, it appears that this laptop has an Atheros 9k series card.

I happen to have a card in the same series, and I've noticed it will get stuck sometimes in a low-performance mode after a suspend, which shows up readily in the dmesg output (I don't have the issue right now, so I cannot provide an example); rebooting a couple of times usually fixed it however, so I'm surprised that yours persisted across multiple reboots. I've had the problem survive a couple of reboots and suddenly start working, but I haven't tracked down the cause. I did notice that rebooting to Windows would always fix the issue, so it may related to some initialization. I know this is probably not the fix you wanted, but if you still have Windows on the machine it's worth a shot.

Removing and reinserting the module (sudo modprobe -r ath9k and sudo modprobe ath9k respectively) didn't seem to fix it, but if the card got stuck the output in dmesg would be different than normal.

However, given that the Panda devices seem to be ralink or realtek, this doesn't explain why the external adapter was slow as well -- there is probably another configuration issue at play there.

| improve this answer | |
  • Thanks for this but I tried daumie's answer and it worked right off the bat. – William Jan 21 '16 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.