1

I have a dual boot system with Ubuntu 15.10 and Windows 10, so I tried to fix the time inconsistency between Ubuntu and Windows by applying the above mentioned widely known fix, but even after reboot Ubuntu keeps assuming that BIOS clock is set to UTC time, while I'd like it to be set to local time to be compatible with Windows.

From some comments to the same answer linked above, it seems that I'm not the only one that has this problem.

Any clue?

Why this question is not a duplicate

Question Clock time is off on dual boot is very generic, and among many possible solutions has the one of making Ubuntu use local time instead of UTC. But the widespread proposed way to achieve that does not work for me and others, so I think there is a need for another question asking why the widespread proposed solution of changing /etc/default/rcS does not work (at least in some cases), and my question addresses such need.

  • 1
    I have posted an answer for the systemd case (should apply to 15.10): askubuntu.com/a/720466/158442. Try it out. Though, IMHO, making Windows use UTC is better. – muru Jan 13 '16 at 3:41
  • @muru I agree that every OS should use UTC, but the problem of making Windows use UTC is that you must disable clock update via internet, since Windows is (still in 2015) not able to write UTC to BIOS time, it always writes local time. In a dual boot system this means that unless you boot Linux, your BIOS time is never updated. – mmj Jan 13 '16 at 10:20
  • ... unless you use NTP on Linux (askubuntu.com/a/178977/158442). Or enable the automatic update available by default: askubuntu.com/a/176184/158442 – muru Jan 13 '16 at 10:23
  • @muru I finally decided make Windows use UTC and turn down Windows time update via internet, but If you are sure your solution of the reverse option (making Ubuntu assume BIOS time is local time) works, put it here as answer (link is enough) and I'll accept it. – mmj Jan 13 '16 at 10:29
  • 1
    Possible duplicate of Clock time is off on dual boot – muru Jan 13 '16 at 10:31
6

As @muru explained on Clock time is off on dual boot and according to the Arch Wiki:

You can set the hardware clock time standard through the command line. You can check what you have set to use by:

$ timedatectl | grep local

The hardware clock can be queried and set with the timedatectl command. To change the hardware clock time standard to localtime, use:

# timedatectl set-local-rtc 1

If you want to revert to the hardware clock being in UTC, do:

# timedatectl set-local-rtc 0

We can make Windows to use UTC but sometimes we have few Windows and only one Ubuntu for our multi boot setup. In this case preferable option is to force one Ubuntu to use 'Local' time rather than changing all Windows settings one by one.

Tested this method on Ubuntu 16.04 LTS Xenial and it's working without any issue.

1

If you wish to update the time immediately use switch:

timedatectl --adjust-system-clock set-local-rtc 1
0

I have a quite simple answer for all the users who don't want to mess up with command lines in Linux. In Windows turn on the automatic time and time zone update as it will set BIOS/hardware clock to local time. Now In Linux, turn off the time zone update and set time zone to UTC or GMT. So, it will assume BIOS time as UTC time (which is now local time set via Windows.) And display the same. And now turn on the automatic time update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.