0

I am using a Transcend class 4 8gb SD card. I am not able to erase the SD using my phone.

1) All the files can be accessed. I cannot send or delete files in the SD card.

2) When I delete the files and folders,they come back after the phone restarts.

3) Gparted is not detecting this card. I tried in a Windows system too.

Can anyone please explain how I might format this card? I'm using Ubuntu.

  • It's an issue related with the card rather that the system it seems. Can you connect the sd card directly via an adaptor? I believe you're using USB with the connection right now. Your sd card is read only right now, so you can't modify it. – biozalp Jan 13 '16 at 0:09
  • I can ask for a replacement but i dont want to give this card coz data can be accesseed. – salm Jan 13 '16 at 8:07
  • Can you connect it via SD card port on the pc? – biozalp Jan 13 '16 at 16:40
  • No matter how much i format. The data keeps coming back. I tried formatting using gparted. – salm Jan 14 '16 at 10:55
  • answer my question, can you connect it via port on the PC? – biozalp Jan 14 '16 at 10:56
1

If it's a standerd SD-card then look for a phisical switch on the side of the card. If it was broken off then you can put some tape over the opening and you should be able to write to it.

  • There is no physical switch. – salm Jan 13 '16 at 8:05
  • Its a transcend class4 sd card. There is no physical switch – salm Jan 14 '16 at 10:56
  • yup. That did it. I plus 1 this. – Bhikkhu Subhuti Aug 14 '17 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.