1

I've used Ubuntu on my Lenovo Y510p for nearly six months with no issues, and I fell in love with it. I recently bought a MSi GS60 (Skylake), and I've had a major problem with running Ubuntu.

I can install it without a problem, but when I boot into Ubuntu, my screen freezes at the login page. Now, with my MSi laptop, I can see when the dedicated nVidia GPU and the integrated one are being used and the freeze occurs when it switches from the integrated GPU to the nVidia one.

I can boot into Safe Mode and install drivers and whatnot without an issue, and it uses the nVidia GPU for this.

I've read up on all the issues nVidia Optimus has with Linux and I've tried several solutions elsewhere on this site.

I tried installing Bumblebee. It didn't fix my problem, and instead I booted into Emergency mode with no GUI. This happened as well when I tried to boot into Recovery mode. So I uninstalled Bumblebee and everything with it.

I tried installing nVidia Prime. The login screen didn't freeze, but whenever I tried to login the desktop would not appear and instead I would get another login screen.

I would like to be able to run Ubuntu, preferably behaving as Windows does and dynamically switching between GPUs to optimize performance. But honestly, I would be happy with just using the integrated GPU when running Ubuntu. Could I get some suggestions as to what to try next?

  • you should probably note in post whether that MSi is a Haswell or Skylake model, ie. post complete model name. dynamically switching between GPUs, not likely ever going to happen in linux in the near future, if ever. When doing a fresh install on the MSi are you enabling 3rd party drivers?, if so don't & see if it can boot & login using just Intel gpu. – doug Jan 12 '16 at 22:31
  • I updated my original post. I'd be completely okay with even just my integrated Intel GPU; I'm still trying to get it to boot properly. I just tried a fresh install without third-party drivers to no avail. – Grant B. Jan 14 '16 at 1:01
  • Where/are you able to boot to the live usb > Try before installing or does that also black screen or loop? I have a 510p which is fine & a skylake laptop which I can boot to & login to an Ubuntu live session though it's not as nice as your laptop, has a nvidia 950m & that works ok. Maybe take a look here, there is a kernel option that some need (I don't), - i915.preliminary_hw_support=1 - askubuntu.com/questions/698168/… – doug Jan 14 '16 at 16:16
0

Normally you should use the NVIDIA drivers from the official Ubuntu repositories.
But because you are having quite new hardware - the 358 drivers might be better.

First remove installed NVIDIA drivers and bumblebee.

Highlight the Ubuntu menu entry and press the E key.
Add nouveau.modeset=0 to the end of the linux line.
Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1.
Enter your user name and the password and execute :

sudo apt-get purge nvidia* bumblebee  
sudo reboot  

Now install the latest official stable NVIDIA drivers.

Highlight the Ubuntu menu entry and press the E key.
Add nouveau.modeset=0 to the end of the linux line.
Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl+Alt+F1.
Enter your user name and the password and execute :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-358 nvidia-prime
sudo reboot  

Open NVIDIA X Server Settings - select PRIME Profiles tab.
Switch to the graphics you want to use, logout and back in.
Dynamic switching is not supported under Linux as of now.

| improve this answer | |
  • When I add the nouveau.modeset=0, I boot to a black screen. I then tried sudo systemctl mask gpu-manager.service following the advice of other posts but it still froze on the loading screen. I tried this with both nvidia-358 and nvidia-prime as well as Bumblebee. Do you have any other suggestions? – Grant B. Jan 14 '16 at 1:09
  • @GrantB. : Please try it again ... this time use the parameter nomodeset instead of nouveau.modeset=0 :) – cl-netbox Jan 14 '16 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.