I installed ubuntu 14.04 on my notebook. I can't access internet even when i am connected to wifi. No matter how many restarts, no matter how many connections-disconnections to the network the internet access dissapears after a short period of time.

With cable works fine, so I am guessing it has something to do with wifi.

ps: I have also installed Windows and everything works great!

lspci -knn | grep Net -A2

04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: XAVi Technologies Corp. Device [1b9a:2485]
    Kernel driver in use: rtl8723be
  • Try disabling ipv6. If you are still having a problem you need to identify your hardware. In general, it is easiest to purchase linux compatible wireless cards which can be 10 or less – Panther Jan 12 '16 at 20:33
  • Please edit your question and add output of lspci -knn | grep Net -A2 terminal command. – Pilot6 Jan 12 '16 at 21:39
  • @bodhi.zazen Disabling ipv6 didnt work! – Skemelio Jan 13 '16 at 11:41
  • Possible duplicate of Wifi problems with rtl8723be in Ubuntu 14.04 – Panther Jan 13 '16 at 11:50
  • Please run the WiFi diagnostics and edit your question to include a link to the result. – David Foerster Jan 15 '16 at 2:37

I googled "RTL8732BE linux driver" which gave me this thread and this, both which looks like exactly your problem.

You'll need to install a proper driver for your wifi adapter. There are answers in both threads that show you how.

  • I hope if installing a new driver for my wifi adapter wont affect wifi-connection on Windows! Thanks for your effort! – Skemelio Jan 13 '16 at 11:42
  • 1
    You need to install it on Ubuntu, so that will not affect your Windows installation. – jogco Jan 13 '16 at 12:19
  • I took courage and followed the first thread. It work! Thanks a lot!! – Skemelio Jan 14 '16 at 0:00

This is based on the Trial with the rtl8732be.conf file located in /etc/modprobe.d/ folder

Create or Edit the existing file by typing the below code in terminal

 sudo gedit /etc/modprobe.d/rtl8723be.conf

Type your root password then copy and paste below given text

options rtl8723be fwlps=N ips=N ant_sel=1

Save the file & Reboot. Now you should have a proper working WIFI.

Hope This helps all of you, This worked on my new HP245 G5 laptop with 16.04.1

Thanks to all who have tried to post information to get this wifi device working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.