23

I installed Oneiric as a guest OS in VirtualBox using the Mini CD. I installed the ubuntu-desktop package and everything seems to work fine - well, except for a font issue with the terminal:

As you can see, some of the letters overlap and it's difficult to read. I checked the settings and it the checkbox "Use the system fixed width font" is checked with "Monospace | 12" selected underneath it.


Edit: running the commands mentioned in the comments:

$ fc-match "Monospace"
DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"
$ gconftool --get /desktop/gnome/interface/monospace_font_name
Monospace 10
$ debsums ttf-dejavu-core
/usr/share/doc/ttf-dejavu-core/AUTHORS                                        OK
/usr/share/doc/ttf-dejavu-core/BUGS                                           OK
/usr/share/doc/ttf-dejavu-core/NEWS.gz                                        OK
/usr/share/doc/ttf-dejavu-core/README                                         OK
/usr/share/doc/ttf-dejavu-core/changelog.Debian.gz                            OK
/usr/share/doc/ttf-dejavu-core/copyright                                      OK
/usr/share/doc/ttf-dejavu-core/langcover.txt.gz                               OK
/usr/share/doc/ttf-dejavu-core/status.txt.gz                                  OK
/usr/share/doc/ttf-dejavu-core/unicover.txt.gz                                OK
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf                      OK
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf                           OK
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf                  OK
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf                       OK
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Bold.ttf                     OK
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf                          OK
  • Which terminal are you using? xterm or gnome-terminal? – Chakra Oct 22 '10 at 6:36
  • 1
    What do fc-match "Monospace" and gconftool --get /desktop/gnome/interface/monospace_font_name return? – ændrük Oct 25 '11 at 18:36
  • I don't know, but I also experienced this issue when upgrading from Ubuntu 11.04 to 11.10. Later I re-installed Ubuntu 11.10 from scratch and I no longer have this issue. – Anonymous Oct 25 '11 at 18:36
  • 1
    This question should instead be filed as a bug report, thanks! Instructions here. – jrg Oct 25 '11 at 18:41
  • @ændrük: I have added the information to the question. – Nathan Osman Oct 25 '11 at 18:43
19

Turns out the ttf-ubuntu-font-family Install ttf-ubuntu-font-family package somehow didn't get installed. Immediately after installing that package, the terminal font switched to the Ubuntu Monospace font and everything was readable again.

  • Ping me with a solution to above problem, so next time I can edit without bothering you... ;) – Fabby Feb 27 '17 at 9:02
2

Open your terminal Go to Edit-->Profile Preferences and in general tab check "Use System fixed width font"

2

I have seen this kind of problem in my friend's gnome terminal.. just go to edit --> profiles and change the settings of the font of your terminal.. it should solve your problem.. :)

2

Had the same problem. This may be related. Bug #1166125

Removing package pango-graphite fixed the problem for me:

sudo apt-get purge pango-graphite
1
  1. sudo apt-get install gnome-tweak-tool

  2. goto tweak tool

  3. goto fonts>monospace> select ubuntu mono regular 13pts

0

Go to Software Center and remove 'monospace font for pretty code listings and for the terminal'.

If that doesn't do it for you, try to remove Terminal (gnome_terminal), log out and log in and install the Terminal(gnome-terminal).

0

I fixed this issue by running: gconf-editor /apps/gnome-terminal/profiles/Default

and unchecking "Use System Font"

0

I fixed mine by using custom font monospace regular on all fronts.

  • 2
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Feb 27 '17 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.