0

I attach my Gigabyte P34Wv4-BW1T laptop to a 2nd monitor via HDMI. This monitor blacks out randomly. I think it's random, at least. I'm not sure if it's going into sleep mode or not. I went into my laptop and monitor settings and turned off any power saving and sleep modes. I tried the nouveau driver, nvidia "proprietary,tested driver" and the nvidia "proprietary" driver and I still have the same problem. I checked my cables and they are not loose.

I'm not sure what type of log would help diagnose the problem. I did do a dmesg -T and couldn't find something in the log that corresponded to the time that this happens.

Maybe the "ACPI Warning" is a culprit? The same problem happened again and I didn't see the ACPI Warning in the dmesg log, though.

Another thing is that when I am playing music through the hdmi cable (the monitor has speakers) and the screen blacks out, the audio shuts off as well. So that's why I thought it was the cable, but the cable is on their tight.

I tried a disabling the nvidia card and using the intel card. That did not help. I also tried connecting via different hdmi ports. Still does not work. Can anybody out there help?

Edit: i removed the nvidia drivers and disabled the nvidia card on my laptop. im just using the intel graphics. still having a problem. any ideas?

Edit: turned off power management (I think) and dpms:

$ xset -q
DPMS (Energy Star): Standby: 0 Suspend: 0 Off: 0 DPMS is Disabled

Edit: I don't see anything when I tail .xsession-errors

Edit: I installed Windows 10 and tried it all out. No problems with blacking out. It's not the cable or the hdmi port. Not a hardware problem! I really need some help.

Edit: It doesn't seem to be happening at a lower resolution of 2560x1080:

HDMI1 connected 2560x1080+1920+0 800mm x 335mm
3440x1440 50.0 + 30.0
2560x1080 60.0*

0

It was my refresh rate. I have HDMI not HDMI 2.0 My refresh rate was 60Mhz which is too high. 3440x1440 60Hz is for HDMI 2.0, not what I have.

xrandr --output HDMI1 --mode 3440x1440 --rate 30

fixed my problem. I just made some scripts I have to run at login to run the command, which isn't too bad...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.