1

I deleted some files from my home folder that added up to about 50GB. They did not go to my Trash, but are no longer in the home folder. I still have the same amount of disk space remaining as I did before I tried to delete them. I do not have a Lost+Found directory, either.

I tried running btrfs balance start '/' but that didn't free up any space.

1

Turns out the quasi-deleted files were moved to a root-only directory called .Trash-0 In order to remove them, I opened that directory as root, as well as another (in my case Documents), and had to cut and paste the files from .Trash-0 to Documents in order to properly delete them.

0

Despite being not really clear your post I am assuming you are looking about how to find out what data is filling up your disk space.

To find out, first of all you will need to check your file system capacity:

df -ah

The above command will show you the FS capacity.

I don't know if you have set up separate partition or all in one partition in your system. I am going with the assumption that you have all in one partition which /.

To check where is the offending data which is filling the system you can use du command as follow (use sudo if you are not root):

du -sh /*

This will show you all subdirectories of / filesystem with the data size.

Let's say you found out that your /home is the biggest size, so you can proceed further, again using du:

du -sh /home/*

And you will see which is the biggest data in your home directory and so on.

If you want to remove the data, you can do it either using GUI based file explorer (i.e. thunar, nautilus, etc.) or in command line as follow:

rm -rf /home/foo

In the above command you are removing whatever foo is, can be either file or directory (mind -r option, removes recursively).

Pls be aware that removing files with -rf option are not sending your data in your trash but they will be erased permanently. So keep in mind and think twice before removing anything, especially in the system side (out of your home dir).

  • Thank you for teaching me some new commands, but I found what I was looking for by accident. – burningserenity Jan 11 '16 at 20:46
  • Note that globs by default don't include hidden files. Use shopt -s dotglob – Andrea Corbellini Jan 11 '16 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.