2

Since I've been using Linux on my Macbook I've noticed that there's a red light constantly shining out of the headphone port on the left side of the machine. This doesn't happen on OS X, I've checked.

I found out it can be turned off via ALSA Mixer by un-checking the fifth "IEC958" option, which viewed in the terminal via "amixer" appears as: 'IEC958',16

"amixer set 'IEC958',16 mute" works and turns the light off so to make this happen automatically at reboot I did this:

"kate .mute". I then added these 4 lines to that file:

"#!/bin/bash sleep 10 /usr/bin/amixer set 'IEC958',16 mute exit"

After saving I then edited .profile with this command: "kate .profile" and added this line to the end of that: "bash .mute &"

For my first few days of using Kubuntu this worked, as soon as I logged in the light automatically went out but then I added the main Kubuntu repo and updated to the newest version of plasma it offers (I was notified of normal system upgrades). Ever since I've done that the light won't turn off. The command to turn it off works and I can do it manually via the ALSA Mixer GUI but it won't go off automatically at login. This is a long one so thanks for your time.

0
2

The solution I found here (search on page for "red light") is

echo '1' | sudo tee '/sys/module/snd_hda_intel/parameters/power_save'

The advice for making it a permanent change is to create a new file

/etc/modprobe.d/audio_powersave.conf

and include the following

options snd_hda_intel power_save=1
1
  • I appreciate the help but that top command doesn't turn the red light of for me. I'm running Kubuntu on a 13 inch 2011 Macbook Pro. – Kupo Mar 6 '16 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.