9

Im trying to install a canon printer driver on 15.10. I know this worked on an older distribution, but now the installation fails:

$ sudo dpkg -i o1512een_linux_CQueDEB_v2010_64.deb 
Selecting previously unselected package cque-en.
(Reading database ... 255576 files and directories currently installed.)
Preparing to unpack o1512een_linux_CQueDEB_v2010_64.deb ...
Unpacking cque-en (2.0-10) ...
Setting up cque-en (2.0-10) ...
Running CQue setup from /opt/cel
/opt/cel/bin/setup: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

Was libXp.so.6 removed recently? Is there a way to make this install?

Edit: It's not available in the official package sources anymore

1
  • Why does this have a downvote? I understand it may not be the best question ever asked but ...?
    – cat
    Jan 21, 2016 at 1:05

8 Answers 8

5

This might not be a perfect or ideal solution, but if you download the .deb for the previous ubuntu release (15.04), it seems to install just fine on 15.10. A program that depended on it started working immediately after I installed it.

http://packages.ubuntu.com/vivid/amd64/libxp6/download

3
  • Also note there is the i386 version for older programs
    – TheSchwa
    Jan 27, 2016 at 18:22
  • The link on the answer is broken. I've used this one.
    – gabra
    Oct 25, 2016 at 18:17
  • 3
    That second link is also broken.
    – JorgeGT
    May 18, 2017 at 15:00
4

Ubuntu Wily has no package named "libXp". Only solution I have found is to install the one from the previous version (download the deb file, install manually). I can't find any justification for this droppage, appears just a goof.

There's a bug report against Ubuntu Wily about it, but no response. https://bugs.launchpad.net/ubuntu/+source/libxp/+bug/1517884

libxp.so is REQUIRED for SAS, a commercial statistics program.

2

This worked for me:

sudo add-apt-repository ppa:zeehio/libxp
sudo apt-get update
sudo apt-get install libxp6

Caution: it requires adding a PPA, so think twice b4. To remove the PPA run

sudo add-apt-repository --remove ppa:zeehio/libxp

Source1, Source2

2
  • This repo is now getting a 404 error Jan 25, 2019 at 15:23
  • Worked for me on Ubuntu 18.04. Thanks! Sep 9, 2019 at 15:01
1

For Ubuntu 16.04 (Xenial Xerus) the following works.

Add the following line to /etc/apt/sources.list:

deb http://security.ubuntu.com/ubuntu precise-security main 

and run

sudo apt update
sudo apt install libxp6:i386

The :i386 suffix is only necessary if you need the 32 bit version.

You may also remove the source line from /etc/apt/sources.list afterwards.

1

Download and install libxp6:

cd /tmp/
wget -q http://ftp.ch.debian.org/debian/pool/main/libx/libxp/libxp6_1.0.2-2_amd64.deb
dpkg -i libxp6_1.0.2-2_amd64.deb
0

If you get libxp being 64 bit errors, or can't find libXp, try installing libxi6:i386

0

Try this command to search how many package in Ubuntu related to libXm and motif.

sudo apt-get install libmotif*

or

sudo apt-get install libXm*

You could see the list of all available lib package.

1
  • 1
    How will this help? How are those packages related?
    – Zanna
    Aug 4, 2017 at 7:43
-1

The output posted indicates what the problem is:

libXp.so.6: cannot open shared object file: No such file or directory

This tells you that you do not have such library installed in your system.

The solution to your problem is to install the missing library as follow:

 sudo apt-get install libXp

After installing the missing library you can install your driver.

1
  • 5
    Unable to locate package libXp Aug 22, 2016 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.