2

Possible Duplicate:
How to remove wine completely

Is there a way to do a reset for ubuntu 11.10 to really uninstall a software such as wine and all of its remaining components. I installed wine 1.3 using these commands:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update
sudo apt-get install wine1.3

Then I used the software center to uninstall wine but that really didn't uninstalled the whole program because it left some folders in the home directory .wine so is there a way to reset ubuntu or really uninstall wine with terminal commands? can you guys please help with the code for the terminal.

marked as duplicate by belacqua, fossfreedom, hhlp, Marco Ceppi Oct 27 '11 at 11:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @belacqua no this is not a duplicate as there was no answer and it was for an unknown wine version. Thankfully burnopereira81 provided kick UP support and provided excellent answer. – jmarc Oct 25 '11 at 17:46
  • I don't think it's different, though @burnopereira81's answer is more direct. His answer would've worked for the original question as well. – belacqua Oct 25 '11 at 20:29
1

If you want to remove wine + all configs and files type this in a terminal

sudo apt-get remove --purge wine1.3.

After that if there is still a ~/.wine folder you are free to delete it using

rm -rf ~/.wine.

  • I get this when I use rm -f ~/.wine rm: cannot remove `/home/user/.wine': Is a directory – jmarc Oct 25 '11 at 17:14
  • After I uninstalled wine 1.3 thru the softwarecenter I installed wine 1.2 aswell I tried sudo apt-get remove --purge wine1.2 like you suggested for wine1.3 but I get this: dpkg: warning: while removing wine1.2, directory '/etc/xdg/menus/applications-merged' not empty so not removed. any help would be awsome. – jmarc Oct 25 '11 at 17:28
  • try not using the --purge flag. – Bruno Pereira Oct 25 '11 at 17:31
  • I got this after using sudo apt-get remove wine1.2: The following packages were automatically installed and are no longer required: ia32-libs-multiarch:i386 libqt4-declarative:i386 liblcms1:i386 libqt4-qt3support:i386 libcupsimage2:i386 libqt4-test:i386 Use 'apt-get autoremove' to remove them. – jmarc Oct 25 '11 at 17:34
  • I used sudo apt-get autoremove seemed to have done the trick. – jmarc Oct 25 '11 at 17:43
0

Wine stores all its files in .wine/ in your home directory.

Remove the .wine/ directory from your home directory.

Then you use alacarte to remove the entries from the menu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.