After installing the latest stable kernel 4.4 on Ubuntu 14.04 I have a problem with virtualbox-5.0_5.0.12-104815-Ubuntu-trusty_amd64.deb. VBOX broke and reinstallation doesn't help.

Recompiling VirtualBox kernel modules ...failed!
(Look at /var/log/vbox-install.log to find out what went wrong)

I tried different methods. I think a problem with a new kernel (?)

  • Well, this kernel was released only yesterday... AFAIK it is not yet supported in the current Virtual Box release. You may help with running Virtual Box Test Builds to report issues to the devs.
    – Takkat
    Jan 11 '16 at 12:10
  • 1
    You can also post /var/log/vbox-install.log here so someone can check it out to find the problem. Jan 12 '16 at 7:25
  • How did you install the 4.4 kernel? If you just grabbed the packages from the mainline "ppa" it won't work.
    – Silviu C.
    Jan 16 '16 at 7:30

Just happened to visit this thread after struggling with the same problem.

As commented by @Javier Rivera in the question, the log did say something:

Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong
not supported by compiler

So the solution is simple: upgrade the GCC suite (at least to 4.9).

For my 14.04 Ubuntu box, the newest one available in official repository is just 4.8, so some hack is needed. Fortunately, this is quite a common problem and is already solved by others:

How to install the latest g++(currently 5.1) in Ubuntu(currently 14.04)?

After installing a newer GCC suite (for me, its 5.3.0), another problem arises when choosing the default compiler for the system, which is also mentioned in the linked guide of the answer to he aforementioned question.

After all of this, double check if you have the right version of gcc:

$ gcc --version
gcc (Ubuntu 5.3.0-3ubuntu1~14.04) 5.3.0 20151204
Copyright (C) 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Reinstall virtualbox as usual, and this time, it shouldn't complain.

  • Please could you add the update-alternatives step to your answer? I was not sure exactly what command should be used looking at the link, so I was unable to edit it
    – Zanna
    Sep 6 '17 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.