i am using Ubuntu 14.04 now i want to upgrade my Ubuntu to the latest version so i run sudo do-release-upgrade in terminal then i getting the below error

Err Upgrade tool signature
404 Not Found [IP: 80]
Err Upgrade tool
404 Not Found [IP: 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'utopic.tar.gz.gpg' missing Failed to fetch Fetching the upgrade failed. There may be a network problem.

please guide me how to resolve this error.Thanks in advance.



At the moment there is no supported way to upgrade Ubuntu 14.04 as 14.10 "Utopic Unicorn" reached end of live in 2015-07-31 and Ubuntu 16.04 isn't released yet.

You need to wait until April when 16.04 will be released.

  • thanks i will wait.can i directly upgrade my Ubuntu 14.04 to 16.04 after April ? – vanakam Jan 12 '16 at 13:43
  • Yes. As 16.04 is the next LTS release after 14.04 the upgrade will be officially supported. – Florian Diesch Jan 12 '16 at 13:55

According to the error message "404 Not Found [IP: 80]" you have a network issue or the used mirror is not working for utopic. Check that you can reach the server listed in /etc/apt/sources.list, try to connect to a different server, if that also fails check your internet connection and outgoing firewall settings.

Kind regards Maddes

  • You may wish to read the other answer. And 404 Not Found is unlikely to be a network issue. It means File Not Found, not Server Not Found. That's because those files have now been deleted from the servers. – Martin Thornton Jan 11 '16 at 13:47
  • i have a reliable net connection so i am sure this is due to not a my net connection.i tried to connect us server by default it is in India server that is also not worked. – vanakam Jan 12 '16 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.