3

I bought a Dell XPS13 9350 a few weeks ago. The wireless card (Broadcom 43a3) was not supported but was supposed to be supported from Linux Kernel 4.4 onwards. that was a long wait, schlepping an ethernet cable around with me, so got the new kernel as soon as it was released today. Yet wifi still does not work. The card works fine (I've got dual-boot with Windows and it works fine there), but for some reason the driver is not installed after the upgrad to 4.4.

Here some helpful output:

$ sudo lshw -C network
  *-network UNCLAIMED     
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:3a:00.0
       version: 08
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:dc400000-dc407fff memory:dc000000-dc3fffff

and

lspci | grep Network
3a:00.0 Network controller: Broadcom Corporation Device 43a3 (rev 08)

and

$ iwconfig
enx9cebe8239db7  no wireless extensions.

lo        no wireless extensions.

The driver is also not blacklisted or blocked:

$ grep -R brcm /etc/modprobe.d

$ rfkill list all
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

If someone knows what's going on here: thanks for all help!

  • I think kernel 4.4 has the driver, but don't you also need the firmware? i.e. don't you need /lib/firmware/brcm/brcmfmac4350-pcie.bin. I think you can get the firmware here – Doug Smythies Jan 11 '16 at 7:13
  • that did the trick. thanks! I guess this can be marked as solved now. – theBanana Jan 11 '16 at 12:39
  • I converted my comment to an answer. – Doug Smythies Jan 11 '16 at 15:08
1

Kernel 4.4 has the driver,

e3c92cb brcmfmac: Add support for the BCM4350 PCIE device.

but you also need the firmware file. You need /lib/firmware/brcm/brcmfmac4350-pcie.bin. One place to get the firmware is here.

0

Had the same problem on Ubuntu 14.04 with the 4.4 kernel and this did the trick for me:

Go to software & Updates, enable"Proprietary drivers for devices"

Reload sources, and apt-get upgrade

It'll grab the latest broadcom drivers and intel microcode, you'll need to >disable secure boot if its enabled, reboot, and it should work.

Source answer by cre8tions

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.