I have just completed a fresh install of ubuntu 15.04. Everything seemed successful, but when I boot I get a black screen with a blinking cursor.

I installed it on an ssd drive (/dev/sda) enter image description here

I tried to reinstall grub2 but it did not work:

sudo mount /dev/sda5 /mnt

sudo mount --bind /dev /mnt/dev &&
sudo mount --bind /dev/pts /mnt/dev/pts &&
sudo mount --bind /proc /mnt/proc &&
sudo mount --bind /sys /mnt/sys

sudo chroot /mnt

grub-install /dev/sda
grub-install --recheck /dev/sda


exit &&
sudo umount /mnt/sys &&
sudo umount /mnt/proc &&
sudo umount /mnt/dev/pts &&
sudo umount /mnt/dev &&
sudo umount /mnt

but the problem still exists.

  • 1
  • I looked over this but the fixes seem to be if you can get into the grub menu. I can't even get that far. I should not that I am using a Nvidia graphics card (gtx780) Jan 10, 2016 at 21:43
  • I have tried to set nomodeset in the grub file as well but the problem still persists. Jan 10, 2016 at 22:07
  • You need to boot with nomodeset using grub menu, then install the driver.
    – Pilot6
    Jan 11, 2016 at 10:41

1 Answer 1


I think the issue is on /dev/sda1. This is the extended partition ... AS A WHOLE ... So therefore it looks like the boot flag should be on /dev/sda5 not /dev/sda1

  • Thanks this was it. So simple can't believe I missed that! Thank you so much Jan 10, 2016 at 23:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.