0

I have a 1TB external USB HDD. I have partitioned it as follows.

Disk /dev/sdb: 931.5 GiB, 1000204885504 bytes, 1953525167 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
Disklabel type: gpt
Disk identifier: 6C3FB5F1-7B50-11E3-BFCD-4C72B91262C0

Device          Start        End   Sectors   Size Type
/dev/sdb1        2048      43007     40960    20M BIOS boot
/dev/sdb2      206848  409806457 409599610 195.3G Linux filesystem
/dev/sdb3   409806848  819406847 409600000 195.3G Linux filesystem
/dev/sdb4   819406848 1229006847 409600000 195.3G Linux filesystem
/dev/sdb5  1229006848 1536206847 307200000 146.5G Microsoft basic data
/dev/sdb6  1536206848 1638606847 102400000  48.8G Linux swap
/dev/sdb7  1638606848 1953523711 314916864 150.2G Linux filesystem
/dev/sdb8       43008     206847    163840    80M Linux filesystem

When I started installing Ubuntu, by picking 'I want to do something else' during the initial setup - to install Ubuntu on external HDD. There I configured the partitions. The first partition /dev/sdb1 is flagged as 'BIOS_GRUB'. (It was recommended by Ubuntu during the installation). Then I configured the 'root' folder for /dev/sdb2 and 'home' folder for /dev/sdb4. I also asked the grub to be installed at /dev/sdb .

The installation went successfully, but after I restarted and tried to boot from the External HDD - it doesn't boot. I have the Ubuntu Live USB through which I am trying to diagnose/fix this.

Questions here are -

  1. What could be possible reasons behind this?
  2. What would be the ways to diagnose this?
  3. If the /dev/sdb1 was flagged as 'GRUB_BIOS' partition, then shouldn't GRUB be installed in this partition, than at the beginning of disk /dev/sdb? (in any case I do not get an option to install GRUB at /dev/sdb1 during the installation).
  4. Some more insights about how-where GRUB is installed and whats' the role of the 'GRUB-BIOS' partition?

Note - This question may look similar to another question on Ubuntu Forum How to Install Ubuntu on Portable External Drive, but it is not. Because I had followed the steps mentioned in that question to install Ubuntu on my External HDD. And the installation is completed successfully. But afterwards my PC doesn't boot, so I suspect this is more to do with GRUB and the various booting possibilities (like MBR, GPT)

1
0

I finally ended up solving my problem, so let me sum up the lessons learned.

  1. I have a Windows-10 PC with UEFI. In that case make sure the Linux installation disk also needs to support UEFI. (check the link for more info )
  2. I had the Linux installation image also with UEFI, but I had activated the compatibility/leagacy BIOS mode on my PC. This was one reason why the image did not work. I rebooted my PC by activating UEFI mode and re-installed Ubuntu, that worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.