I went into CompizConfig Settings Manager to disable a setting in the Grid plugin (Snap windows back to original size.)

As soon as I checked it off, the screen flickered for a moment, the launcher disappeared, all windows lost their borders and clicking on them did nothing. Whenever I try to log into that account on regular Unity, I either see my desktop and nothing else, or my desktop along with the taskbar up top with Nautilus's menus. (I can't provide screenshots ; printscreen button does nothing.) If I open a window with the Nautilus menu, it has no borders, and I can't click on anything. The only way I've found to interact with anything in this state is to bring up the virtual terminal with Ctrl+Alt+F1, but I have no clue how to fix anything from there.

I can still log into Unity on all other accounts, and I can still use Unity2D on the affected account. How do I get Unity up and running again? Thanks.

  • exactly the same happened to me like 10 minutes ago. thanks for asking this! – Richard Rodriguez Oct 25 '11 at 16:30

You ought to be able to reset the Compiz configuration to the defaults by running

unity --reset

This should make Unity work again.

  • Turns out that the problem can be solved by re-checking the "Snap windows back to original size." Then you can run the command "unity" in the terminal or just reboot the computer. However, I recreated the problem and can attest to "unity --reset" working as well. When I clicked off the offending check box again, I saw "Segmentation fault" in the terminal window again. Guess it's time to learn how to file bug reports, 'cuz this one was pretty bad and is probably reproducible by anyone. – Doval Oct 25 '11 at 20:43

Seems that the Unity Plugin got deactivated in CCSM.

When you're on the empty desktop create a new file, open it, type ccsm and save the file. Close it and via right click and properties make the file executable. Then launch it and CCSM should open. Check if the Ubuntu Unity Plugin got unchecked.

  • Great idea, didn't occur to me. Unfortunately, the Ubuntu Unity Plugin is still checked, so I guess that wasn't the issue. I tried unchecking it and rechecking it. I also tried rechecking the option on the Grid plugin that caused all this, nothing. – Doval Oct 25 '11 at 16:54
  • try going to unity 2d, enable the unity plugin there, then re-login to unity 3d – Richard Rodriguez Oct 25 '11 at 17:12
  • Tried that just now, didn't help either. Then I used the text file trick to run /usr/bin/gnome-terminal and ran unity, this is what I got – Doval Oct 25 '11 at 17:39
  • Wow, "Segmentation fault". That is a bug in Compiz. (Unless it goes away if you, say, reboot the machine -- then it could be an indication of flakey hardware causing memory corruption.) – Marius Gedminas Oct 25 '11 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.