I have a Lenovo E31-70 laptop, with Qualcomm Atheros QCA6174 (rev20) wifi card. I managed to get it working using this solution.

Everything worked fine until about a week ago, when I ran the auto-updates, and then my wifi suddenly died..

So now I have 14.04 with 4.2.0-23 kernel, but this is what I get with dmesg | grep ath10k

[    1.915931] ath10k_pci 0000:03:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[    2.125714] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[    3.339234] ath10k_pci 0000:03:00.0: qca6174 hw2.1 (0x05010000, 0x003405ff, 168c:003e:17aa:3044) fw WLAN.RM.1.1-00141 api 5 htt 3.1 wmi 4 cal otp max_sta 32
[    3.339239] ath10k_pci 0000:03:00.0: debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[   64.921977] Modules linked in: drbg ansi_cprng ctr ccm thinkpad_acpi nvram msr acpi_call(OE) arc4 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core v4l2_common videodev media rtsx_usb_ms memstick btusb btrtl btbcm btintel snd_hda_codec_realtek snd_hda_codec_generic joydev snd_hda_codec_hdmi intel_rapl iosf_mbi x86_pkg_temp_thermal intel_powerclamp coretemp snd_hda_intel kvm snd_hda_codec snd_hda_core snd_hwdep crct10dif_pclmul crc32_pclmul ath10k_pci ath10k_core ath mac80211 aesni_intel i915 bnep aes_x86_64 lrw gf128mul glue_helper rfcomm ablk_helper snd_soc_rt286 snd_soc_rl6347a bluetooth drm_kms_helper cryptd snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine input_leds drm serio_raw snd_pcm lpc_ich cfg80211 mei_me mei shpchp snd_seq_midi snd_seq_midi_event snd_rawmidi wmi i2c_algo_bit snd_seq snd_seq_device ideapad_laptop sparse_keymap snd_timer snd ak8975 inv_mpu6050 industrialio_triggered_buffer binfmt_misc i2c_hid hid kfifo_buf industrialio i2c_mux soundcore video dw_dmac dw_dmac_core snd_soc_sst_acpi 8250_dw i2c_designware_platform i2c_designware_core spi_pxa2xx_platform nls_iso8859_1 mac_hid acpi_pad parport_pc ppdev lp parport rtsx_usb_sdmmc rtsx_usb psmouse ahci r8169 libahci mii sdhci_acpi sdhci

I had to rename the board.bin to board-pci-168c:003e:17aa:3044.bin in /lib/firmware/ath10k/QCA6174/hw2.1 to get rid of another line of "cannot direct load ..." but the wifi still doesn't work. It can connect to my router, but it drops off quickly and stays that way after that.

Can I somehow sort out this mess? I tried reinstalling the http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.149.2_all.deb

and also went to git to get the ath10k files for QCA6174/hw2.1 but still no luck.. Should I just upgrade to 15.10?

If possible I'd like to avoid that at any cost as I prefer LTS releases..

In my understanding 14.04.3 LTS's firmware does not have a driver for Qualcomm Atheros QCA6174, that's why I had to upgrade to the backported newer kernel and install it's firmware. And it did work really well but I fail to understand what went wrong with the updates? Have I messed something up, or am I missing something?

Thanks so much for any help in advance!

  • OK, so I recovered the original installation of my laptop using CloneZilla and an image I made a week ago when everything was working just fine.. But the Wifi still doesn't work. The only thing that changed is I changed countries, and I'm in the UK now, whereas before the laptop, driver, firmware was installed in Hungary Budapest. Now I'm in London, using a regular BT hub, one that we've been using here for years without a problem.. Is it possible that the laptop that used to work perfectly with another router suddenly has unreliable, extremely slow wifi which dies every 5 second? Thanks! – danielhomola Jan 12 '16 at 14:53

Sorry for the confusion, looks like our UK router was at fault (BT hub). It does not have 802.11ac mode, so I had to switch it back to 802.11a from 802.11ng, on the 5Ghz and now the wifi is working with my laptop.

Thanks for your help and answers anyway!

  • Changing my BT router to drop back to 54Mbps did fix my hugely unreliable Wifi, but it feels like this isn't really solving the problem. What happens when I use someone else's BT Hub? Seems like it might be a Wifi firmware issue... – Gordon Williams Nov 1 '16 at 18:59

First boot with a perivious kenel using grub menu to see if it is not a kernel regression and see if Wi-Fi works.

Then try to install the latest firmware from the "wily" repository.

It looks like the parameter setting was omitted and may help

echo "options ath10k_core skip_otp=Y" | sudo tee /etc/modprobe.d/ath10k_core.conf

Reboot

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.