4

I bought a new acer E5-574g-50XN laptop with linpus linux. I removed linpus and installed ubuntu. But the touchpad is not working. I googled tried many things but couldn't fix it.

uname - r gives 4.2.0-23-generic  
xinput --list shows "SYN1B81:01 06CB:7406 UNKNOWN   id=12 [slave pointer (2 )]  

dmesg shows i2c-hid i2c-SYN1B81:01 :failed to retrieve report from device.

I also tried settings synclient TouchpapOff=0 but it automatically gets to TouchpadOff=2.

When I blacklisted i2c-hid touchpad stopped working completely.
I am a student and I wanted to learn about linux but I am really frustrated right now. And also when I switch off the laptop and leave it for some time then use it, touchpad works for a little time and then starts lagging heavily. It never stops working but lags so much that it is unusable.

5
  • Sorry i could not paste complete output because my laptop is almost unusable and i don't know much about shortcuts of ubuntu. Please help me!! – user3125971 Jan 10 '16 at 9:47
  • Did you have windows installed on this laptop with the same problems? If Win works without any problems and you want to use Ubuntu, you can install it using virtual machine (VM) e.g.: VMware Player or Virtualbox... – Dimitri Podborski Jan 10 '16 at 11:01
  • I have not tried windows yet – user3125971 Jan 10 '16 at 11:05
  • @markkirby OP says they installed Ubuntu. – andy256 Jan 10 '16 at 12:05
  • I know this is probably not an issue, but for the users that look in the future; Possible answer in another thread: askubuntu.com/questions/763763/touchpad-under-16-04-not-working Check that out, hopefully it works! – MBarnes Dec 14 '16 at 19:36
6

I just solved it by changing touchpad from advanced to basic in main tab of bios settings.

3
  • Does it work simultaneously with an external mouse? – moonstar Dec 28 '16 at 8:05
  • Same here. What does advanced do? What will we miss? – Jaec Jun 26 '17 at 4:23
  • 1
    this will cause two finger scrolling and other features to be disabled if you boot in to windows – Warren Scantlebury Sep 10 '17 at 0:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.