0

I'm using ubuntu 15.10 and a beginner of Linux/GNU system.

I know almost next to nothing about VPN's detail too. So the terminology about VPN might be wrong.

I and my colleagues use a server with VPN. However the network admin changed the protocol to IPsec/L2TP. We were told the server's name, dns server, pre shered key, username and password.

After reading some questions and answer in this website, I guess that IPSec/L2TP with pre shared key has become difficult since 14.10.

However, reading this question and answers, I decided to try Network Manager L2TP plugin

But...the installation never worked. I'm confused and have no idea.

I did that as following:

$ apt-get install strongswan network-manager-strongswan

 

$ LANG=C sudo add-apt-repository ppa:seriy-pr/network-manager-l2tp
WARNING:root:could not open file '/etc/apt/sources.list'
WARNING:root:could not open file '/etc/apt/sources.list.d/ubuntu-ja.list'
WARNING:root:could not open file '/etc/apt/sources.list'
WARNING:root:could not open file '/etc/apt/sources.list.d/ubuntu-ja.list'
 Packages for https://github.com/seriyps/NetworkManager-l2tp
Screenshot: http://dl.seriyps.ru/img/network-manager-l2tp.png
Full description (in russian) http://seriyps.ru/blog/2012/01/31/plagin-l2tp-dlya-networkmanager/
Installation:
sudo apt-add-repository ppa:seriy-pr/network-manager-l2tp
sudo apt-get update
sudo apt-get install network-manager-l2tp-gnome
!!!!!!!!!!!!!!!!!!
sudo service xl2tpd stop
sudo update-rc.d xl2tpd disable
!!!!!!!!!!!!!!!!!!
 詳しい情報: https://launchpad.net/~seriy-pr/+archive/ubuntu/network-manager-l2tp
[ENTER] を押すと続行します。ctrl-c で追加をキャンセルできます
WARNING:root:could not open file '/etc/apt/sources.list'
WARNING:root:could not open file '/etc/apt/sources.list.d/ubuntu-ja.list'
gpg: keyring `/tmp/tmpdb17vvm8/secring.gpg' created
gpg: keyring `/tmp/tmpdb17vvm8/pubring.gpg' created
gpg: requesting key B11E44D2 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpdb17vvm8/trustdb.gpg: trustdb created
gpg: key B11E44D2: public key "Launchpad PPA for Sergey Prochorov" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK

 

$ LANG=C sudo apt-get update
...
...
Ign http://ppa.launchpad.net wily Release.gpg                                                             
Ign http://ppa.launchpad.net wily Release
...
...
Err http://ppa.launchpad.net wily/main amd64 Packages                                                   
  404  Not Found
...
...
Err http://ppa.launchpad.net wily/main i386 Packages            
      404  Not Found
Ign http://ppa.launchpad.net wily/main Translation-en
Ign http://ppa.launchpad.net wily/main Translation-ja
Fetched 840 kB in 12s (65.3 kB/s)                              
W: Failed to fetch http://ppa.launchpad.net/seriy-pr/network-manager-l2tp/ubuntu/dists/wily/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/seriy-pr/network-manager-l2tp/ubuntu/dists/wily/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

  

$ LANG=C sudo apt-get install network-manager-l2tp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package network-manager-l2tp

As the outputs show, I can't install network-manager-l2tp. I can't understand these outputs exactly.

How can I solve this?

Here is the network manager modules that I installed.

$ LANG=C apt list network-manager-*
Listing... Done
network-manager-dbg/wily-updates 1.0.4-0ubuntu5.2 amd64
network-manager-dev/wily-updates 1.0.4-0ubuntu5.2 amd64
network-manager-gnome/wily,now 0.9.10.1-0ubuntu7 amd64 [installed]
network-manager-iodine/wily 0.0.5-1ubuntu1 amd64
network-manager-iodine-gnome/wily 0.0.5-1ubuntu1 amd64
network-manager-openconnect/wily,now 1.0.2-1build1 amd64 [installed,automatic]
network-manager-openconnect-gnome/wily,now 1.0.2-1build1 amd64 [installed]
network-manager-openvpn/wily,now 0.9.10.0-1ubuntu2 amd64 [installed,automatic]
network-manager-openvpn-gnome/wily,now 0.9.10.0-1ubuntu2 amd64 [installed]
network-manager-pptp/wily,now 0.9.10.0-1ubuntu1 amd64 [installed]
network-manager-pptp-gnome/wily,now 0.9.10.0-1ubuntu1 amd64 [installed]
network-manager-strongswan/wily,now 1.3.1-1ubuntu1 amd64 [installed]
network-manager-vpnc/wily,now 0.9.10.0-1ubuntu1 amd64 [installed,automatic]
network-manager-vpnc-gnome/wily,now 0.9.10.0-1ubuntu1 amd64 [installed]

P.S: I know there are some answers that suggest to use openswan but I don't want do that as possible. I'm afraid of security issues.They say openswan has been removed because of security risk. I'm using ubuntu for working desktop so I can't ignore security risks intentionally.

0

Sergey Prokhorov has not created a version for Wily (yet?). You can see this in the link you have posted. The plugin works up to Ubuntu 14.X (tested on 14.04). By the way, do you need L2TP over IPSec or not? Strongswan is for the one and Prokhorovs plugin for the other I think. Not an expert though.

Cheers, Oliver

  • and i think it is sudo apt-get install network-manager-l2tp-gnome – Oliver Kennel Apr 6 '16 at 18:10
  • Please make your answer more concrete (add links in place and avoid noisy comments which don't contribute to the answer). – Karl Richter Apr 7 '16 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.