5

I have SONY VAIO SVF15319SNB laptop with Windows-10.

I re-partitioned the disk to install Ubuntu 14.04.

Installation was fine but after restarting the system, I am not able to get the dual boot options. System is starting with default Windows.

I tried the 2nd option mentioned in below link: install Boot-repair in Ubuntu.

https://help.ubuntu.com/community/Boot-Repair

It worked fine for first time, but once I re-booted the system and started the windows then again restarting the system, its not showing ubuntu option and starting in Windows.

I have the pastebin while trying to repair using the above mentioned option:

http://paste2.org/hnW6xV2W

Please help me on this.

4
  • Thank you cl-netbox for your help. I disabled the fast boot and executed the mentioned command. But in BIOS i cannot find option to select Ubuntu as default system. But after restarting first time i got ubuntu option, but same problem persist. When I booted to Windows and shut down the system again started in Windows without showing any other option. Please help me on this. Thank you Nico for your help, but when I change the BIOS Mode to legacy, my laptop started crying and message was "Operating System not found". – Dinesh P. Jan 11 '16 at 15:12
  • 1
    Sony (and others) violate UEFI spec. They use description as part of UEFI boot and only valid description is "Windows". There are several work arounds. Did you try the suggested edit to BCD that Boot-Repair gives. Other work arounds: askubuntu.com/questions/486752/… Boot-Repair also should copy shim to bootx64.efi if you tick the Use standard EFI file option. bugs.launchpad.net/boot-repair/+bug/1531178 – oldfred Jan 11 '16 at 15:19
  • Shutdown Do Not Restart; second edit or comment on your post this section is for answers. – DnrDevil Jan 11 '16 at 15:22
  • You're welcome ! There must be an option in BIOS to switch - at this point I am actually unable to help you, because every hardware vendor ships with different BIOS / UEFI versions ... and maybe you have to enable a setup mode or set a password ... please repeat everything and then check the BIOS / UEFI options again. Another possibility when you really cannot find a switch : Did you install Ubuntu using wubi ? If that's the case, it might not work, Ubuntu has to be installed the recommended way by creating an install media. :) – cl-netbox Jan 11 '16 at 16:03
4

Boot into Windows, disable hibernation and Fast Boot.
Open command prompt as administrator and execute:

powercfg /h off  

Open the "old" version of Windows Control Panel.
Go to the Power Settings and uncheck Fast startup.
In case it is not visible, enable show hidden settings.

Shutdown the machine completely, do NOT reboot.
Boot into BIOS and select Ubuntu as default system.
Now you can select the OS to boot from GRUB menu.

0
1

In the BIOS settings, double check the BIOS Mode is in legacy and not UEFI. This did the trick for me.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.