8

While downloading the components of Android Studio it was showing a message

IBus prior to 1.5.11 may cause input problem. See IDEA-78860 for details.

So how can I get to know which version of iBus am I using and how to update it to iBus 1.5.11?

  • "See IDEA-78860 for details." why did you not include the details to the question? – Rinzwind Aug 6 '16 at 19:02
  • @Rinzwind Probably because it is hard to find. This looks like the bug report, which Google doesn't show. Perhaps some sort of robots.txt issue: youtrack.jetbrains.com/issue/IDEA-78860 – nealmcb May 27 '17 at 22:30
4

You can run the command ibus version to see which version you are running. I'm still personally trying to figure out how to update it myself

edit: I found a post that breaks down installing the newest version of ibus, link.

Also in case you run into the same error I did when attempting to install it, if you run into the error saying your intltool is too old run:

sudo apt-get install intltool

When you run the make command stated in the above link, you might get a lot of missing packages. For the most part just install them one by one and if need be google to find the source package for some.

| improve this answer | |
  • Thank you, this helped when I ran into a similar issue with JetBrains Rider! – Matthew Groves Mar 27 '16 at 3:47
4

The version of iBus or any package that you are using is normally found using apt-cache policy package where "package" is the name of the package that the software belongs to. In the case of iBus the package is called "ibus":

➜  ~ apt-cache policy ibus
ibus:
  Installed: (none)
  Candidate: 1.5.11-1
  Version table:
     1.5.11-1 500
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        500 http://httpredir.debian.org/debian unstable/main amd64 Packages

In my system, there's no iBus installed, but if I were to install it, I would get the 1.5.11 version. You can figure out which version is available for any release of Ubuntu using madison:

 ibus | 1.4.1-3ubuntu1   | precise        | source, amd64, armel, armhf, i386, powerpc
 ibus | 1.5.5-1ubuntu3   | trusty         | source, amd64, arm64, armhf, i386, powerpc, ppc64el
 ibus | 1.5.5-1ubuntu3.2 | trusty-updates | source, amd64, arm64, armhf, i386, powerpc, ppc64el
 ibus | 1.5.9-1ubuntu3   | vivid          | source, amd64, arm64, armhf, i386, powerpc, ppc64el
 ibus | 1.5.10-1ubuntu1  | wily           | source, amd64, arm64, armhf, i386, powerpc, ppc64el
 ibus | 1.5.11-1ubuntu2  | xenial         | source, amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
 ibus | 1.5.11-1ubuntu3  | yakkety        | source, amd64, arm64, armhf, i386, powerpc, ppc64el, s390x

If you want a release of Ubuntu that includes 1.5.11 or later, I recommend using xenial or later.

| improve this answer | |
0

This is how I checked that my install of ibus was correct (the first command is to make sure ibus is present)

$ command -v ibus
/usr/bin/ibus

$ ibus version
IBus 1.5.14
| improve this answer | |
  • 1
    The ibus version command was already mentioned in the accepted answer. – Kevin Bowen Oct 13 '16 at 9:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.