0

I already asked this question in the Acer Community- if someone answers there, I will share the solution. But hopefully someone here will be even faster.

As mentioned in a different thread, I finally got Ubuntu 15.10 installed on my E5 573G-71L9. At first, the wireless LAN was not working, but I managed to find and install the presumably correct drivers.

What I did was: first ensure that I had the correct r8168 driver for the Realtek card, downloaded from the Realtek site.

As wifi still didn't work, I also figured out that it was the Atheros card that needed a proper driver. I followed this method (I basically just copied-pasted all commands without understanding them completely): Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation

This brought my wireless connection to live, but I got disconnected frequently, about every two minutes. According to the network manager, I am still connected, but I can't even ping the DNS server (I can ping localhost). Sometimes the connection gets restored after some time, other times I need to 'disconnect' and reconnect again.

In addition, I purged the r8168 driver that I downloaded from Acer and installed the r8168 from the Ubuntu Software Center - no difference. I also replaced the Atheros driver with the one that solved the problem for a person with the same system configuration (see other thread). For me, it did not work.

My regdomain is set to Germany (where I live). I tried to disable hardware encryption (nohwcrypt=0) and various other parameters for iwlwifi that were suggested in several forums and on askubuntu, which I don't really remember anymore (nothing worked, so I removed them all from the /etc/modprobe.d/ files, so they should be 'clean' again.

Wired internet works without any problems.

dmesg | grep ath10k

[   12.529816] ath10k_pci 0000:03:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[   12.835697] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[   13.299474] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/board-2.bin failed with error -2
[   15.171270] ath10k_pci 0000:03:00.0: qca9377 hw1.0 (0x05020000, 0x003820ff sub 11ad:0806) fw WLAN.TF.1.0-00267-1 fwapi 5 bdapi 1 htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 features ignore-otp
[   15.171273] ath10k_pci 0000:03:00.0: debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[   15.228201] ath10k_pci 0000:03:00.0 wlp3s0: renamed from wlan0

With the ethernet cable disconnected, I executed the wireless-info script, as provided at Ubuntuforums. As the file is too large to copy here and attachments are not allowed, I put the output in my public Dropbox folder: https://dl.dropboxusercontent.com/u/22984057/Acer/wireless-info.txt

I would be grateful for any pointers in the right direction. Thanks!

  • Can you change the SSID of the router? – Jeremy31 Jan 10 '16 at 20:39
  • Yes, I can change the SSID manually and I can edit the wireless connection. In addition, I can also see my neighbors' networks listed (I don't have there passwords, of course). – Eelco Herder Jan 11 '16 at 22:49
  • I also tried the live versions of Ubuntu 14.04 LTS, Mint and Ubuntu-Mate (both latest version). None of them recognized the wireless adapter out of the box. – Eelco Herder Jan 11 '16 at 22:52
1

I finally found a solution for this problem. Or rather, the solution has been implemented for me: the required drivers are now part of the Ubuntu 16.10 distribution. It works out of the box :-).

0

If you can rename the wireless routers SSID, I would change it to a name without any spaces. Make it Kristof&Eelco and change the channel from auto to channel 6. Reboot the router and test

  • Ah, you mean changing the name of the router itself, not in the network settings of the laptop. Why exactly do you think that would make a difference? I haven't tried it out yet (our other computers, tablets and cell phones also make use of the router), but thus far the router name has worked fine with several versions of Ubuntu (and Android and Windows). Is there any evidence that the Atheros driver is sensitive to spaces and channel settings (which work for all devices except for this laptop) or any reason why this might work? Thanks again! – Eelco Herder Jan 13 '16 at 0:37
  • Change the name of the router itself, I saw it posted once on ubuntu forums and the spaces did cause a strange response from the wireless script. Changing the channel it is on could fix it by itself. Another option is to use Network Manager and set the IPv6 setting to ignore – Jeremy31 Jan 13 '16 at 10:12
  • I changed the name of the router into Kristof&Eelco and set the channel to 6. That didn't make a difference. In addition, I also set the IPv6 setting to 'ignore'. Alas, the wireless lan still disconnects randomly (and frequently). – Eelco Herder Jan 13 '16 at 20:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.