4

This question already has an answer here:

i want to remove wine1.7 from my Ubuntu 14.04 trusty tahr. But when i typed in sudo apt-get purge wineit didn't worked i gives me

package not installed

so i typed sudo apt-get purge wine(tab)and it showed the packages so i did

sudo apt-get purge wine1.7 wine1.7-amd64 wine1.7-i386 wine-gecko2.34 wine-mono4.5.4 winetricks 

i uninstalled wine but told me to do

sudo apt-get autoremove

to remove the orphaned packages but when i did autoremove it broke my system.Fortunetly i had a clonezilla partition backup so i got back my OS from a week ago but it had

wine

installed so im back to where i started.So my question is how to remove wine and its dependencies without breaking my system ? and here are the packages that are orphaned according to apt but as i said when i do sudo apt-get autoremove it breaks my system

here are the packages

The following packages were automatically installed and are no longer required:
  fonts-horai-umefont gcc-4.8-base:i386 gnome-exe-thumbnailer icoutils
  libasn1-8-heimdal:i386 libasound2:i386 libasound2-plugins:i386
  libasyncns0:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libcapi20-3 libcapi20-3:i386 libcups2:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libelf1:i386
  libexif12:i386 libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1:i386
  libfreetype6:i386 libgcrypt11:i386 libgd3:i386 libgif4:i386
  libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
  libglib2.0-0:i386 libglu1-mesa:i386 libgnutls26:i386 libgpg-error0:i386
  libgphoto2-6:i386 libgphoto2-port10:i386 libgssapi-krb5-2:i386
  libgssapi3-heimdal:i386 libgstreamer-plugins-base0.10-0:i386
  libgstreamer0.10-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
  libheimntlm0-heimdal:i386 libhx509-5-heimdal:i386 libice6:i386
  libieee1284-3:i386 libjack-jackd2-0:i386 libjbig0:i386 libjpeg-turbo8:i386
  libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386
  libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386 libldap-2.4-2:i386
  libllvm3.4:i386 libltdl7:i386 libmpg123-0 libmpg123-0:i386 libodbc1
  libogg0:i386 libopenal1:i386 liborc-0.4-0:i386 libosmesa6 libosmesa6:i386
  libp11-kit0:i386 libpcap0.8:i386 libpciaccess0:i386 libpng12-0:i386
  libpulse0:i386 libroken18-heimdal:i386 libsamplerate0:i386 libsane:i386
  libsasl2-2:i386 libsasl2-modules:i386 libsasl2-modules-db:i386 libsm6:i386
  libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0:i386 libssl1.0.0:i386
  libstdc++6:i386 libtasn1-6:i386 libtiff5:i386 libtxc-dxtn-s2tc0:i386
  libusb-1.0-0:i386 libv4l-0:i386 libv4lconvert0:i386 libvorbis0a:i386
  libvorbisenc2:i386 libvpx1:i386 libwind0-heimdal:i386 libwrap0:i386
  libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
  libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386
  libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
  libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
  libxml2:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
  libxshmfence1:i386 libxslt1.1:i386 libxt6:i386 libxxf86vm1:i386
  ocl-icd-libopencl1:i386 odbcinst odbcinst1debian2 p11-kit-modules:i386 p7zip
  unixodbc wine-gecko2.34:i386
Use 'apt-get autoremove' to remove them.

marked as duplicate by David Foerster, WinEunuuchs2Unix, TheWanderer, Eric Carvalho, Zanna Nov 21 '16 at 13:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What I'd try is doing the whole thing with aptitude remove. First, install aptitude with apt-get install aptutude and then do sudo aptitude remove wine* and it should tell you the best way out to avoid breaking things. Not necessarily the answer to your question in its entirety but something that has helped me heaps in the past. – sbergeron Jan 9 '16 at 15:34
  • 1
    it shows that aptitude will remove the dependencies also and all the packages that apt showed. This will too certainly break my system – Shantanu Bedajna Jan 9 '16 at 16:19
  • It could be that some amd64 required packages has been replaced by their i386 while installing wine before. Try sudo apt-get install ubuntu-desktop then check again apt-get -s autoremove (-s means simulate only, not real run) – user.dz Nov 20 '16 at 21:31
0

i would suggest using apt-get autoremove and after it is done use synaptic or something to fix broken dependencies. Not sure if this will work but is what i would try. i removed wine and used the apt-get autoremove on my 15.10 and it worked fine. maybe you need to do a system update or something. one thing i didnt do is sudo apt-get purge i usually use synaptic an right click and select mark for complete removal it had me install a generic version of somehting cant quite remember now but then i auto removed most of the same things you did and it asked me to reboot and booted just fine.

0

Try this:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get autoremove
sudo apt-get purge wine*
sudo apt-get autoremove

That should refresh the cache and make sure you have absolutely all updated packages, then remove the unnecessary packages, before removing wine and some more 'unnecessary' packages.

If nothing works, just ignore them. 99.99% of users have more than enough disk space to keep them.

  • Basically for problems like this I try various combinations of the above commands until it works. It's the birdshot tactic. – Daniel Jan 10 '16 at 3:54
  • i did exactly that but that broke my system .seems like system thinks that all those packages are orphaned but they are certainly needed it breaks the desktop environment to be specific .I have gnome and cinnamon installed none of them works , only cinnamon starts in failsafe mode. – Shantanu Bedajna Jan 10 '16 at 18:53
  • Well, then just leave them there and ignore them. In this day and age, unnecessary packages don't take up precious disk space, because disk space is so plentiful. Just leave them there. – Daniel Jan 10 '16 at 21:06
  • autoremove is like throwing a MP into a room hoping it will only kill bad guys. – frlan Nov 21 '16 at 13:58
  • @frian and commenting on a year-old thread is like running back to base hoping to kill camping snipers. You won't find anybody there. – Daniel Nov 22 '16 at 21:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.