0

I have a MaaS server, it has two network interfaces. One external eth0, and one for the internal network eth1(Nodes network). eth1 is where the DNS and dhcp server managed interface. I want a mix of physical servers, and one KVM VM run on the MaaS server. I manage to create VM's to PXE Boot, and created a bridge br01 bridged with the eth1 interface.

auto br0
iface br0 inet dhcp
        bridge_ports eth1
        bridge_stp off
        bridge_fd 0
        bridge_maxwait 0

And that bridge is associated with the VM's network.

Now this works if created on an external server connected to the eth1 network(tried earlier as proof of concept).

But what I want is to move this KVM setup over to the MaaS Server itself(to free up a physical server as Node), and then this network configuration is not working.

The network part of the VM's xml file:

<interface type='bridge'>
      <mac address='52:54:00:3c:a5:18'/>
      <source bridge='br0'/>
      <model type='virtio'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>

I created the VM using:

sudo virt-install --name=bootstrap-juju --ram=2048 --vcpus=1 
--disk path=/var/kvm/images/bootstrap-juju.qcow2,bus=virtio,size=20 
--pxe --graphics=vnc --hvm --network bridge=br0,model=virtio 
--os-variant=ubuntuprecise

It seems that there is a problem with the bridge, when I sudo ifup br0 I get:

DHCPDISCOVER on br0 to 255.255.255.255 port 67 interval 3 (xid=0xcb27ff35)
No DHCPOFFERS received.

So it seems the bridge is not getting DHCP address from the internal dhcp server.

Does anyone have any pointers here?

  • Please post the interface section of your xml definition file, /etc/libvirt/qemu/server_name.xml. The interface should be defined as type=bridge and be set to using br0 as the source bridge. see also here and here. – Doug Smythies Jan 9 '16 at 16:26
  • Updated my question with more info. Thanks for reply. – ladrua Jan 9 '16 at 20:58
  • Yes, I saw, but everything looks O.K. so I am stumped. The only other things I can think to look at are the guest /etc/network.interfaces file and the output from ifconfig on the guest. – Doug Smythies Jan 9 '16 at 22:55
  • I meant to write /etc/network/interfaces yesterday. Perhaps post both files for both the host and the guest. your sudo ifup br0 command was done on the host right? On my host I get ifup: interface br0 already configured – Doug Smythies Jan 11 '16 at 15:31
1

Ok, I had a few problems. My eth1 was still defined as static in my /etc/network/interfaces. I had to remove it, and change my br0 with matching static settings. Then on the Cluster master in MaaS, change the Managed DHCP-DNS interface from eth1 to br0.

Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.