3

With 14.04 LTS I had no problem play at rock steady 75fps. Now with the 15.10 it's wandering crazy ~40-50fps with sudden drops for ~5sec to 1fps. I have the latest Intel Graphic Drivers:

*-display               
   description: VGA compatible controller
   product: 3rd Gen Core processor Graphics Controller
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:31 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:3000(size=64)

With Dota running:

$ free -h
         total       used       free     shared    buffers     cached
Mem:          7,7G       6,9G       818M       1,2G       272M       4,2G
-/+ buffers/cache:       2,4G       5,3G
Swap:         7,5G         0B       7,5G

Top 6 processes:

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+COMMAND                        
28343 user     20   0 3943112 1,460g 299876 S  58,7 19,1  30:47.57 dota2                                                                                                 
32596 dinky     20   0  756176 126840  54304 S  13,0 1,6 2:15.09 plugin-containe     
7 root   20 0 0 0 0 S 6,5 0,0 0:08.30 rcu_sched                         
2399 root      20   0  217364  37004  20248 S   6,5  0,5   2:17.94 Xorg
9 user -11 548336 12016 8784 S 6,5 0,1 0:37.72 pulseaudio                
1 root 20   0   37756   5952   4064 S   0,0  0,1   0:01.82 systemd    

temps:

$ sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +74.0°C  (crit = +128.0°C)
temp2:         +0.0°C  (crit = +128.0°C)
temp3:        +55.0°C  (crit = +128.0°C)
temp4:        +57.0°C  (crit = +128.0°C)
temp5:         +0.0°C  (crit = +128.0°C)
temp6:       +127.0°C  (crit = +128.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +75.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +75.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +73.0°C  (high = +87.0°C, crit = +105.0°C)



$ uname -a
Linux user-HP-ProBook-450-G0 4.2.0-23-generic #28-Ubuntu SMP Sun Dec 27 17:47:31 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


$ cat /etc/*release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.10
DISTRIB_CODENAME=wily
DISTRIB_DESCRIPTION="Ubuntu 15.10"
NAME="Ubuntu"
VERSION="15.10 (Wily Werewolf)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 15.10"
VERSION_ID="15.10"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

And even using a lightdesktop environment (lubuntu). Why is this misfortune happening to me?

  • Hi Phil, Much thanks for your suggestions. The temperature is still at 127, I think this one was always like that, probably broken sensor idk... However after applying all of your suggestions i had ~40fps. I figured to look for new kernel and saw that unofficially the 4.3 was out on 8th of Dec 2015. I installed it and now it's again rock steady 75fps. <3 – Francis Ue Jan 9 '16 at 14:39
2

Your temp6 is 127°C!!!! Either your laptop gets too hot, or somehow ubuntu sensors are messed up.

Either way, I think i know what is the cause of your problems, because something similar happened to me after updating my kernel to the 15.04 one (i'm still on 14.04) and in my case it was the fault of intel_pstate.

To determine if you DO have the same problem, i once had: put

dmesg

in a terminal after playing Dota 2 and experiencing the rapid fps drop! If you have any lines that include the following:

intel_powerclamp: Start idle injection to reduce power

then you most probably have the same issue as i once had, if not then something else is going rough. This is how i solved it:

  1. install indicator-cpufreq, that will let you switch performance states of your CPU:

    sudo apt-get install indicator-cpufreq
    
  2. reboot and get to the GRUB menu press 'e', then put

    intel_pstate=disable
    

    as kernel parameter in the line where it starts with "linux /boot" just after "quiet splash".

After it boots: click the iconide of cpufreq, it should look something like this: enter image description here

Either select "Conservative", or a frequency 2-3 steps below your maximum. It should take care of all such overheating problems, as it did in my case

Samsung NP550P5C-S02GR intel core i5-3210M + HD4000, GT 650M Ubuntu 14.04.3 (Vivid LTS enablement Stack)

0

Another workaround for the intel_powerclamp which is dropping the fps:

sudo rmmod intel_powerclamp
cd /etc/modprobe.d
sudo su
echo install intel_powerclamp /bin/true  > intel_powerclamp.conf

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.