1

Hello I have a 64GB microSD card (Samsung or Sandisk) and when I format it in the Ubuntu Laptop it works fine. When I use it in my Canon camera and I formatted so I can record when I try to mount it back to the Ubuntu it gives me the

Error mounting /dev/sdc1 at /media/angel/CANON: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sdc1" "/media/angel/CANON"' exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'

and instead of use it again I have to reformat it.

The interesting part is that if I try to read it on a Windows machine (same laptop , dual boot) there is no error.

Also I tried an other sd card which works without problem both ubuntu and windows.

How can I fix the problem at Ubuntu?

3

I found that what is missing can be installed via terminal

sudo apt-get install exfat-fuse exfat-utils

It worked for me in Ubuntu 14.04. It is automounted like any external storage!

I found the answer here.

  • Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, merged into another one or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... – Fabby Apr 13 '16 at 8:14
  • @Fabby You are tottaly right! Never thought about this! Chears – trelozakinthinos Apr 13 '16 at 12:29
  • Good! answer now! Upvoted! ;-) – Fabby Apr 14 '16 at 7:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.