0

I'm having an issue with Windows fonts not being smoothed in Ubuntu 15.10. I copied the contents of the Fonts directory from my Windows 10 install to /usr/share/fonts/truetype/windows10 and ran fc-cache -fv. Afterwards, I rebooted, and the fonts seem to work, but they are not smoothed. Screenshot below. What's odd is that they are smoothed in the font selection menu, but not in the document. Another thing that's odd is that the i, f, and t characters are smooth, but not the other ones. How do I fix this? I'm running the latest Libreoffice 5.0.4 from the Libreoffice PPA (ppa:libreoffice/ppa).

EDIT: I've confirmed that the font smoothing issue is system-wide.

bad font smoothing

0

LibreOffice doesn't use anything but the freeware font engine so all MS and Monotype fonts will look bad as they are hinted or prepped for the Windows font engine.

Also, LibreOffice doesn't license any fonts from monotype so it's not the best solution if you create a document in Times New Roman in MS office, then open it up in LibreOffice - it will default to some random opensouce (typically poor quality) font.

Update:

If the bug is only with a single font:
You can find the fonts in /usr/share/fonts/truetype and edit them with any application you like.
Remember that in the Ubuntu repository you can find alternative versions of almost any character; often, open versions are better than proprietary ones.
If the bug is with many fonts:
A temporary solution is to use substitution table in character styles options to substitute the bad font with the good ones. You can also set the default fonts in the Writer options.
Another solution can be to tweak the characters options for the page: right click -> characters -> position -> distance. And make it fixed by disabling the default, it should be better.
If you can't solve, please consider of downgrading your libreoffice with Synaptics package manager (Menu -> Package -> Force version).
Hope you solve, my eyes would implode with a similar bug. :)

EDIT: if one of the following solutions works try to tweak the font rendering configuration by editing the files in /etc/fonts/conf.d/; use sudo nano /etc/fonts/conf.d/FILENAME on a terminal to do it.
For example try to disable font antialiasing by editing 10-antialias.conf (replace true with false); the same for 10-hinting.conf. If nothing changes symply re-replace false with true.
Please note that you will disable these features for the whole system, so revert the changes if they doesn't help.
The last possible cause of your problem can be the graphic rendering of the driver itself. You can try to execute sudo nano /etc/libreoffice/soffice.sh and ENABLE/DISABLE the OpenGL support. Restart Libreoffice after each edit.
If you can't solve downgrade or use OpenOffice or an equivalent suite, for your eyes (I'm not kidding).
I'm sorry if I wasn't of great help, but I don't know the source code of LibreOffice, I'm only trying various possibilities. :-)
Let us know if you solve or if you discover interesting things.

PS: I copied it from Ugly LibreOffice font

  • So how do I fix this? Is there a way to convert the fonts to the Libreoffice font engine? – Degru Jan 9 '16 at 1:35
  • I will update it – Olimjon Jan 9 '16 at 1:52
  • OK, none of these fixed the problem. I think this is a different issue entirely. I'll try downgrading to Libreoffice 5.0.2 from the default repo. – Degru Jan 9 '16 at 2:07
  • OK, I've also just confirmed that the issue is system-wide. – Degru Jan 9 '16 at 2:11
0

I fixed the issue by installing Infinality using this guide: http://www.webupd8.org/2013/06/better-font-rendering-in-linux-with.html

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Mark Kirby Jan 9 '16 at 14:57
0

System-wide font smoothing (anti-aisling)

This really isn't a Libreoffice problem but as you point out a system-wide problem. The easiest way I know to solve it is with the Tweak Tool. In my case I'm using unity-tweak-tool. Install it with:

sudo apt install unity-tweak-tool

Usage

Start it from Dash or the command line using unity-tweak-tool.

Click on the icon "Fonts" and notice this part of the screen:

Unity tweak tool Fonts.png

The Text scaling factor is only increased for HDPI (High Dots-Per-Inch) monitors such as 1920x1080. The other two fields are the ones that worked best for me to smooth out fonts.


Available tweak tools

To list available tools for your Ubuntu version use:

$ apt-cache search tweak-tool
gnome-shell-extension-autohidetopbar - GNOME shell automatic topbar hider
gnome-shell-extension-suspend-button - Gnome-shell extension to modify the suspend/shutdown buttons
gnome-shell-extensions-gpaste - GPaste extension for GNOME Shell
gnome-tweak-tool - tool to adjust advanced configuration settings for GNOME
unity-tweak-tool - configuration tool for the Unity desktop environment

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.