I'd like to access my Grub Menu at boot by pressing Shift. After I press Shift I see a message saying "Grub loading.." but then no menu appears and the computer keeps booting normally into my Ubuntu Installation. Do you know how I can access the Grub Menu at boot? Thanks a lot for your help!

  • 1
    I fiugred that out, the value GRUB_HIDDEN_TIMEOUT in the file /etc/default/grub has to be set to a value greater than 0. – lucacerone Oct 25 '11 at 11:29
  • If this solves your problem, you can answer your own question with this information and mark it as correct. Then other users will see this question is answered. – Kris Harper Oct 25 '11 at 12:31
  • I can do that only after 8 hrs... Will do it tomorrow.. – lucacerone Oct 25 '11 at 15:59
  • Sounds good. A lot of users never update their questions. Glad you solved your problem. – Kris Harper Oct 25 '11 at 16:08

The issue is solved by modifying the parameter GRUB_HIDDEN_TIMEOUT in the /etc/default/grub file (need to be super user to modify it), and (as always to apply configuration changes made in this file) running sudo update-grub.

Changing the value from 0 to some positive value allows to enter the GRUB menu by pressing Shift during boot.

For those not familiar with updating your GRUB settings:

  1. Press Ctrl+Alt+T to open a terminal.
  2. Run gksu gedit /etc/default/grub.
  3. Change the GRUB_HIDDEN_TIMEOUT line as above, save it, and close gedit.
  4. Run sudo update-grub. You can now restart.

If you want from the GUI

To open the terminal:

Open Dash (Super Key) or Applications and type terminal

enter image description here

For older or Ubuntu versions:

Applications -> Accessories -> Terminal

Then type the command gksu gedit /etc/default/grub

and then change the value in GRUB_HIDDEN_TIMEOUT as above.

enter image description here

Save it and close the editor.

and run sudo update-grub in the terminal.

enter image description here

| improve this answer | |

This finally worked for me :

  1. Goto your BOOT menu and then go to BOOT settings - change "BOOT MODE" to "Legacy" from "UEFI" --> Save
  2. Shut Down and restart.
  3. In my case, it showed "No operating system found"
  4. Quick shut down your system(by pressing the power button continuously for 15 secs)
  5. Goto the Boot menu again and reverse the Boot mode back to UEFI.
  6. Restart your System. This time most probably the GRUB menu will appear.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.