0

I have installed lamp on Ubuntu 15.10. Apache is working fine. Whenever i tried to start the server it says. bash: /etc/init.d/httpd: No such file or directory. Please help.

  • What command did you run to start the server? – Michael Lindman Jan 8 '16 at 13:53
  • $/etc/init.d/httpd start – Goutham Sridhar Jan 8 '16 at 13:56
  • Ah, current versions of Ubuntu use systemd and the start command is sudo systemctl start apache2.service and for earlier versions using upstart the command is sudo service apache2 start. Ubuntu hasn't used /etc/init.d/ for starting services for quite a while now. – Michael Lindman Jan 8 '16 at 14:01
  • 1
    Possible duplicate of How to enable or disable services? – Michael Lindman Jan 8 '16 at 14:02
1

$/etc/init.d/httpd start will not work on Ubuntu, Debian/Ubuntu support listed below commands and CentOS/RHEL support service httpd restart:

How to start Apache 2:

 sudo service apache2 start

How to stop Apache 2:

sudo service apache2 stop

How to restart Apache 2:

sudo service apache2 restart

How to reload Apache 2:

sudo service apache2 reload
| improve this answer | |
  • Thanks a lot. Can you please tell me how do i run perl programs on the server. – Goutham Sridhar Jan 8 '16 at 14:04
  • @GouthamSridhar If you have new question please ask it by clicking on the Ask Question button. – Michael Lindman Jan 8 '16 at 14:07
  • I appreciated it. – Ramesh Chand Jan 8 '16 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.