1

Has any body managed to install metatrader4 on ubuntu15 using wine? Because I have trouble installing it. Thanks,

4
  • 1
    According to wine hq this program has garbage rating on 15.04 and a bronze on 14.04, the last working version was on 12.04, it seems you can not install this on wine as of now, compatibility has dropped over the last few releases. appdb.winehq.org/objectManager.php?sClass=version&iId=2893 – Mark Kirby Jan 8 '16 at 13:18
  • There's very little possibility that a random folk who would see the question tried in wine a specific program you're asking for. If you want an answer, write the details: what exactly gone wrong, why doesn't it installing, are there any errors when running from terminal? – Hi-Angel Jan 9 '16 at 10:31
  • there are no errors it just doesn't open ... – Michael Apr 27 '16 at 12:16
  • @Michael run the app from terminal, like wine metatrader.exe, and tell if you see any errors. Also, please, mention nickname with @ so that the one whom you're writing to would be notified. – Hi-Angel May 5 '16 at 13:42
3

Run:

cd ~ 
sudo dpkg --add-architecture i386 
sudo add-apt-repository ppa:wine/wine-builds 
sudo apt-get update 
sudo apt-get install --install-recommends winehq-staging 
wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks 
chmod +x winetricks 
WINEARCH=win32 winetricks --isolate mt4
3
  • This is the correct answer, thank you so muhc (i just changed the --isolate mt4 to mt5 (dont know it really makes any difference) – user2582318 Jan 16 '17 at 4:34
  • 'mt5' is a non-existent verb, and will cause Winetricks to only create a 32-bit prefix at ~/.local/share/wineprefixes/mt5 . Using mt4 will automate the installation of Metatrader 4. – QwertyChouskie Jan 16 '17 at 22:59
  • yes, thats why i used the mt5, it created the mt5 (i want the mt5) and it worked like a charm – user2582318 Jan 17 '17 at 1:07
0

I just successfully installed MetaTrader 4 on Ubuntu 16.04, using the command provided by Michael. Thanks, Michael! I've been struggling for a while.

Just want to add one more comment, rm ~/.wine folder after using his command, this will clean all the mess of previous installations. (maybe difficult if you have already installed some applications on wine). And then run the installation executable downloaded from MT4 official site. That works for me.

0

Wine

Here are the commands to install Wine:

type dpkg-reconfigure && dpkg-reconfigure debconf -f noninteractive
dpkg --add-architecture i386
apt-get install -qy python-software-properties
curl -s https://dl.winehq.org/wine-builds/Release.key | apt-key add -
add-apt-repository -y https://dl.winehq.org/wine-builds/ubuntu/
apt-get install -qy --install-recommends wine-staging winehq-staging

Note: For the full script, please check this provision.sh file.

Above steps are based on the recent Wine packaging related changes.

See also: How to install and configure Wine?

MetaTrader

Installation of MetaTrader should work under Wine.

Here are the methods:

  • Run the web installer from the website.
  • Use winetricks via: winetricks mt4 command. One-liner:

    sh -s mt4 < <(curl -s https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks)
    
  • For non-interactive installation, check the FX-MT-VM project (under scripts/).

    Note: I'm the author and maintainer.

0

I have also received a lot of errors from wine when installing mt4 on ubuntu x64 again and again. Sometimes I formated my PC again and again.

But then I had understood how to install and open.

Should be installed wine32 if you use x64, and winetricks.

winetricks parameter "--isolate mt4". But you should install the mt4.exe file of your own broker. Then it will work :)

like this video:

how to install mt4 on x64 ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.