This question already has an answer here:

I have just installed Ubuntu 15.10 on my PC and I want to reconfigure network interfaces. I added /etc/network/interfaces file as follows:

auto wlan0
iface wlan0 inet static
    address 192.168.1.4
    netmask 255.255.255.0
    gateway 192.168.1.1

However, after change, I restart network-manager service, my network interfaces not working:

picture's link

But when I delete the above script, everything is fine. Anyone have problems like me?

PS: I can't also find /etc/udev/rules.d/70-persistent-net.rules. Where is it?

marked as duplicate by muru, Pilot6, David Foerster, Mark Kirby, Eric Carvalho Jan 9 '16 at 14:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • That's how Network Manager is intended to work. – muru Jan 8 '16 at 9:33
up vote 0 down vote accepted

The connection managing tool used by ubuntu is network-manager. If you edit your /etc/network/interfaces file you're going to disable network-manager for this interface. The result is it will not be shown.

You can use nmcli -d to show if they are managed or not:

$ nmcli -d
DEVICE  TYPE      STATE      CONNECTION 
wlp4s0  wifi      connected  YOUR-SSID   #Managed
wlp5s0  wifi      unmanaged  --          #Not managed
enp3s0  ethernet  unmanaged  --         
lo      loopback  unmanaged  --        

Solution 1

You can remove the lines again and restart the system. Then use network-manager cmd-line tools nmcli or the gui shown in your screenshot to configure the network connections.

Edit Connections -> SSID -> Edit -> IPv4 Settings -> Manual -> Add address

Solution 2

Or don't remove these lines and use wpa_supplicant and wpa_client to connect and manage the connection yourself in /etc/network/interfaces.

  • No problem. Please mark the answer if it was the solution to your problem. – André Jan 10 '16 at 0:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.