0

Today my nautilus started beeing stuck in fullscreen. Upon opening nautilus you will get the a full screen nautilus. F11 does not do anything and in the nautilus options is nothing to disable fullscreen mode.

I uninstalled nautilus, reinstalled it, deleted its folder in ~/.config, rebooted several times without any success.

This seems to be a bug with compiz because this is not the first time I got windows stuck in such states.

What can I do to get nautilus working normal again?

Using SUPER+S to get into the desktop overview lets you move nautilus to the side like in the second screenshot, but as soon as you click on it, it will turn to fullscreen mode again.

Nautilus in fullscrenn Nautilus moved to the side, still "fullscreen" mode

2

First you need to kill all nautilus instances (not as root):

killall /usr/bin/nautilus

This should not show any running instances:

ps ax | grep nautilus

just something like:

4556 pts/18   S+     0:00 grep --color=auto nautilus

Then just change the window size settings in dconf with:

dconf write /org/gnome/nautilus/window-state/geometry "'640x480+0+0'"
dconf write /org/gnome/nautilus/window-state/maximized false

This should resize the window settings.

1

You can also accomplish this with a GUI in dconf-editor.

First, killall nautilus (not as root).

Under org > gnome > geometry, set that to something less than the size of your monitor, and set Maximized to off.

Note that you may keep having to repeat this step. If you accidentally move a Nautilus window to the top of the screen, it may repeatedly over-ride this setting and decide it will maximize without a top bar. Set the size to 640X480 or something like that.

[EDIT] despite having done these steps, I still get the issue occasionally. I don't see an "org > gnome > geometry" field in dconf-editor under Ubuntu 16.04 LTS. However there is a field "org > gnome > nautilus" where it is possible to affect the geometry of a window and whether it is maximized. This only affects how nautilus starts a window if I understand correctly. If I slide a window to the top of my home monitor, it automatically maximizes and the top bar dissappears, also it always stays on top of all other windows. So far the only fix I've found is to "killall nautilus" and start again. I've verified that the standard keyboard shortcuts and right-click options do not do anything but minimize the window, will not make it unmaximize.

1
  • On ubuntu 20.04 the key to update was initial-size for me. geometry doesn't exist. – David V. Jun 17 '20 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.