0

Any idea what goes wrong with my dual monitor setup?


I've a notebook with Nvidia 525M graphics card and default Unity installed. With the Nvidia Optimus driver 352.63 and switched to the Nvidia card I get output using either the plugged in HDMI monitor or the internal notebook display.

enter image description here

When I try to use both monitors in parallel by expanding the desktop over both displays the windows manager goes crazy. It expands the desktop/window area over both displays but fails to increase the pixels to the sum of both displays: enter image description here

And the nvidia-settings dialog does not show the correct pixels nor the HDMI monitor or something - Even when I use the HDMI device only (internal display deactivated):

enter image description here enter image description here

Curious is also:

  • Top panel is shown correctly.
  • Mouse pointer is shown correctly - Of course you can't easily hit a button since it is misplaced on the screen image.
  • The displays are correctly identified but their possible resolutions list are switched between displays.
  • This happens in 14.10, 15.04 (upgraded) and 15.10 (upgraded).
  • Using internal display and the same display from HDMI port connected to the VGA port instead the dual monitor setting works without any flaw! (Sadly this is not a solution since the display I will use in the future does not have a VGA port any more.)

I'm currently on 15.10 Ubuntu using Unity.

My ~/.config/monitors.xml shows:

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="HDMI-0">
          <vendor>MAX</vendor>
          <product>0x089c</product>
          <serial>0x00000001</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="LVDS1">
          <vendor>AUO</vendor>
          <product>0x129e</product>
          <serial>0x00000000</serial>
      </output>
      <output name="VGA1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
  <configuration>
      <clone>no</clone>
      <output name="LVDS1">
          <vendor>AUO</vendor>
          <product>0x129e</product>
          <serial>0x00000000</serial>
          <width>1600</width>
          <height>900</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="VGA1">
      </output>
      <output name="VIRTUAL1">
      </output>
  </configuration>
  <configuration>
      <clone>no</clone>
      <output name="HDMI-0">
          <vendor>MAX</vendor>
          <product>0x089c</product>
          <serial>0x00000001</serial>
          <width>1680</width>
          <height>1050</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
      <output name="LVDS-1-0">
          <vendor>AUO</vendor>
          <product>0x129e</product>
          <serial>0x00000000</serial>
      </output>
      <output name="VGA-1-0">
      </output>
  </configuration>
</monitors>
0

On Ubuntu 14.04, I could fix that issue by changing the display settings on Compiz. Have a look at 14.10 Dual Monitors are displayed as distorted single screen mode

On CompizConfig Settings Manager, go to "General Options", then "Display Settings" and do the following:

  • Uncheck Detect Outputs
  • In the Outputs array, set the resolutions of each of your screens. The numbers after the resolution 1920x1080+0+0 are the offset. It's important to add this offset according to your needs. I have two full HD screens, so I added the following configuration:
    • 1920x1080+0+0
    • 1920x1080+1920+0

The second output has an offset of 1920, because it is on the right side of the first output, which has a width of 1920.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.