0

I have just followed what was given to me in this question's answer, but in my, case, things are a little strange.

When I say ls /dev/ | grep sd, I get the following screen:

Notice how it ends at sdc2

After connecting my external USB HDD, I get this from the above command:

sdd and sdd1 are now there, from connecting my external HDD

So clearly it picks up my external drive, since now it shows the extra sdd and sdd1. But when I run fdisk -l, it does not pick up sdd and sdd1:

Ends at sdc, not sdd

So clearly fdisk did not pick up my external drive. When I run sudo mnt /dev/*sdd1* /mnt, as suggested in the referenced question above, it says special device /dev/*sdd1* does not exist. (Note, also tried this with /dev/sdd1 /mnt, and no luck)

Can anybody shed some light on what's going on with my external drive? It worked earlier today in Windows 10 and Ubuntu, but now for some strange reason it is working in neither Windows nor Ubuntu.

NOTE:

It is a Transcend 1TB external USB drive, and I am using Ubuntu 14.04

NOTE 2:

After running dmesg | tail, as suggested by Service Manager in the comment below, I get the following:

Picks up the external this time, but still can't access it

So this command's output shows my external drive with all its details, but I still cannot access/mount it.

4
  • After you plug in your drive, type dmesg | tail and include that output in a comment, or edit in your question. – Caturday Saint Jan 7 '16 at 22:14
  • 1
    Try pugging it in to a USB 2.0 port. Also try it it another computer to make sure the hardware isn't bad. Another thing that could be happening is a lack of power to the drive, try another power supply. – QwertyChouskie Jan 10 '16 at 23:21
  • @user4901968 already connected it to my laptop too, and no luck either. In windows 10, it keeps on freezing the computer, even if I try to use the disk management tool...the drive is broken, right? – Konrad Jan 11 '16 at 3:19
  • In latest portable HDDs they could be mounted again once they left not connected for few hours(>6h). Observed this in Transcend and Seagate 2TB Expansion – minion91 Dec 2 '17 at 4:48
2
+50

Since it does not work on either computer, either the drive is dead, the enclosure is dead, or the enclosure is not getting enough power. Try taking the drive out of the enclosure and testing it, and also try putting the drive in a different enclosure. You could also try a different power supply for the enclosure.

2
  • most informative answer. I guess my drive is dead then :( – Konrad Jan 17 '16 at 13:03
  • It could be the enclosure also, you should test that before disposing of it. – QwertyChouskie Jan 18 '16 at 23:50
0

I had a similar experience with a bunch of broken USB sticks. One of them was shown under devices with a partition, but I couldn't access it with gparted or fdisk not even overwrite with dd. Sorry Konrad I assume it's broken.

0

I had a similar problem, years ago, my solution was easy, the drive was not fully inserted into the adapter.

The drive loose, because the manufacturer "forgot" to use the screw that should hold have the drive in place. Simply moving the drive knocked it loose enough that while the system, with errors, saw the drive it was unable to read or write to the drive.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.