0

I'm really stuck with trying to increase the size of the partition sda5 which is a lvm2. I'm quite new to linux and am really pulling my hair out here.

From what I've read, LVM's are supposed to be really flexible but I'm not finding it to be so.

In this GParted screenshot, you can see sda2 and sda5 are locked. Now I've read quite a few articles saying boot off a dvd, which is what I've done here. I've tried the umount command but it says it is not mounted.

If someone has any advice on where to proceed, it would be greatly appreciated.

enter image description here

  • You probably want to start with this website to learn about how to use LVM – Charles Green Jan 7 '16 at 22:05
  • Thanks for the nice article. Its making a lot more sense now that I've had some sleep. I think the best bet is for me to move this lvm to another drive which is a lot larger. – Daryl Van Sittert Jan 8 '16 at 7:44
  • Space helps a lot, thats for sure. Because I'm really lazy, my disk is only three partitions: a boot partition, a swap partition and a big everything else partition. – Charles Green Jan 8 '16 at 14:25
0
Have you you tried trying to change the amount of the partition while having booted from a USB or DVD and having clicked "try Ubuntu without installing" or anything to similar to that.
So what I mean to be specific is to: 
    1)boot from USB or DVD
    2)click "Try Ubuntu without installing" 
    3)Then trying the partition you would like
  • Hi Andy. I booted directly from the gparted iso, so I thought that would be ideal for altering partitions or volumes. I'll try boot from ubuntu in memory this weekend. – Daryl Van Sittert Jan 8 '16 at 7:29
  • Ahh okay yeah gparted doesn't let you edit volumes that you're currently using or so that's what I read back when I had this issue. Doing what I did which I mentioned above worked for me so hopefully it does for you as well. Lmk how things go – Andy Jan 8 '16 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.