2

I have a system with 4 hard drives. It is configured like this:

/dev/sda - windows system, default partitions

/dev/sdb - storage, ntfs

/dev/sdc - storage, ext4

/dev/sdd - ubuntu system

It is a non-UEFI installation for both OS. If I recover Windows boot manager, PC boots into Windows which is normal. If I use grub, Ubuntu boots normally, but I cannot boot into Windows. Windows entry is displayed in Grub menu, but if I select it, I get some blue screen that says:

A required device isn't connected or can't be accessed

Error Code: "0xc0000025"

I have tried installing Grub on /dev/sda and /dev/sdd with the same result. If I try to recover Windows using Windows DVD, automatic recovery does not work, I have to enter the command prompt and run fixmbr, fixboot and other commands to recover my Windows. It happens if Grub is either on /dev/sda or /dev/sdd.

If I recover Windows, I cannot boot into Ubuntu by selecting Ubuntu installation disk as boot device from BIOS - I get grub rescue prompt.

How can I have Grub working with both OS?

  • With Windows 10, did you turn off fast start up or its always on hibernation. Grub cannot boot a hibernated Windows. And Windows will keep all NTFS partitions mounted so you cannot even use a shared NTFS data partition. I might keep Windows boot loader in sda, so you could directly boot Windows. It may keep turning on fast start up on updates and then you need to directly boot to turn it off with BIOS or one time boot key. – oldfred Jan 7 '16 at 18:28
1

Boot from the Ubuntu installation media.
Select Try Ubuntu without installing.
Open a terminal and execute :

sudo mount /dev/sdd* /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda  

Note : * = Ubuntu root partition (e.g. sdd1)

Identify the Ubuntu partition with GParted.
The tool is included in the installation media.
Now both systems appear in the GRUB menu.

Update including the information given by @oldfred

In case Windows does not boot from GRUB boot menu,
disable hibernation mode and fast startup in Windows.
Open command prompt as administrator and execute :

powercfg /h off  

Open the legacy version of the Windows Control Panel (not the modern one).
Select Power Settings, enable show hidden settings and uncheck fast startup.
After having done this - shutdown the computer completely - do NOT reboot.

Note :

Generally it is recommended to install all operating systems to the same disk !
You may want to consider installing Ubuntu to sda where Windows is installed.

  • I absolutely must have both OS on different disks. I have resolved my problem - my GRUB menu has two entries for Windows Recovery, one is for /dev/sda1 (Win Recovery Partition) and one for /dev/sda2 (Windows installation is there). Booting to either of them boots Windows successfully (not the recovery as it states) – Karolis Ryselis Jan 10 '16 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.